Reach M+ WiFi issues with Navio2

I have a new Reach M+, Navio2, and Reach RS+. Reach RS+ and Navio2 seem to work as expected independently. I am having trouble with Reach M+. I can’t seem to get it to connect to my network while connected to the Raspberry Pi 3 B+(the one hosting the Navio2) while using USB. If i power the Reach M+ from my laptop or independent USB power source it seems to work - correctly connect to my wifi network. The Web UI is a bit slower to load than i would expect but I have never worked with one of these before.

If powering through my RPi I have noticed that Reach M+ indicates that it’s connected to my network (slow blink blue light, solid orange and green) but the IPV4 address assigned by my router is not accessible. In the Reach app will show the Reach M+ but only with an IPV6 address and is not accessible as long as it’s powered via USP through Raspberry Pi. I have tried powering the Raspberry Pi via BEC and independent USB power source but seems to make no difference. The only thing that seems to work is if i power the Reach via USB separately from the RPi. The docs show the Reach M+ connected to the Raspberry Pi using USB and explicitly indicate not to use a separate power source for the M+ so i’m really lost. Anyone experienced this and know of a solution?

I have tried re-flashing and multiple attempts at adding and clearing the network.

ReactView version: 2.18.1

Looking through the forums and internet I found this post which seems very similar. I’m going to try to power the Reach via external USB and use the UART cable to pass data to Navio2. It’s disappointing because a simple USB cable for power and data reduce all the extra things needed to supplement the power for Reach M+.

Hi @beeeeee,

I’ll try to reproduce your issue and write back to you once there is any news.

Hi @beeeeee,

I’ve tested Reach M+ powering from RPi USB port, and it seems to work fine. Have you tried this connection using other cables?

Some photos of your hardware setup can give us more information about what may cause this issue.

I tested with 6 different USB cables ranging from 4 inches to 3 feet. Not all were very highest quality but some of them were very high quality USB cables. I have since started using the UART connection and it works without issue but I do wish that i could use the USB connection. I would need to put it back together using USB to take a picture but it was simply a Stampede RC car with a Raspberry Pi 3 B+, Navio2, Reach M+, and a Spectrum receiver. The Reach was connected to the Raspberry Pi USB port ( i tried all of them). The system is powered using a BEC from the Stampede’s Speed controller but I tested powering from a 2000mah usb power and a 2.4ah port on a battery connected to the raspberry pi.

Hi @beeeeee,

I’m afraid it’s hard to understand your hardware setup without photos. They can provide us a lot of info to analyze.

  1. How many devices are powered by Navio2?
  2. Does the same issue occur if only Reach M+ is connected to Navio2?
  3. What is the LED status of Reach M+ when powered from Navio2 USB port?

Hi @gleb.gira,

You are helping me with the other issue i’m encountering and are probably aware that i’m going to re-image. After that is complete I’ll snap a photo and upload in just a bit.

  1. Just Reach M+ connected to USB. I do have a receiver, servo, and of course the speed controller plugged into the servo ports.
  2. Yes
  3. Slow blinking blue light, solid orange and solid green

Here are the two setups. I have eliminated all other devices to reduce variables. In both cases power is being supplied by a 2,000 mah power supply.

Reach M+ Connected to Raspberry Pi 3B+ hosting Navio2. Lights are all solid.

It makes a hotspot available. After connecting with my phone this is what I see. After tapping Reload i just get a solid grey screen forever. Multiple attempts to try again result in the same results.

After connecting with UART it properly connected to the available configured network. Please note that the blue light is slow blinking. It’s an unfortunate coincidence that this was not captured in the photo. I believe the lack of connection to the proper network, which is expected, was an anomaly as I have seen it in go both ways. Although, It seems to follow this pattern way more often. The ability to connect is always the same.

and of course I can connect.

Hi @beeeeee,

Thanks for the detailed test description!

May I ask you to try using Fing app to figure out Reach IP address?
After that, you can enter that IP in your browser and get access to ReachView.

Let me know if it works.

Hi @gleb.gira,

I have Fling so i reconnected the Reach M+ on usb and it started up the hotspot, again for some unknown reason it did not attached to the available network that is configured. However, an IPV4 address was assigned set immediately and the UI was available just like one would expect. I have done this test over 10 times testing various USB cables, power supplies, and USB ports. This is the first time it has worked (everything is the exact same as yesterday), but it does work. I’m going to try disconnecting to see if it is working consistently.

Hi @beeeeee,

Please keep us posted. Does your issue still appear?