Reach M+ Serial connection to PixHawk (ArduRover)

I’m trying to use Reach M+ with Tallysman GNSS antenna as an only GPS unit for PixHawk1 board running ArduRover 4.0.0.

Reachview version 4.22.5, firmware updated yesterday.

Question 1: when connecting Reach m+ serial S1 -> PixHawk GPS (Serial 3), should pins be connected like in docs OR so that RX pins -> TX pins and TX pins -> RX pins?

(consider Reach m+ serial pinout: https://docs.emlid.com/reachm-plus/img/reachm-plus/specs/reachm-connectors.png and PixHawk serial pinout: https://www.google.com/url?sa=i&url=https%3A%2F%2Fwww.pinterest.com%2Fpin%2F586171707724457685%2F&psig=AOvVaw2Z5EJONOJMfzv-VWGZpRYW&ust=1593942826051000&source=images&cd=vfe&ved=0CAIQjRxqFwoTCOC3lv-ps-oCFQAAAAAdAAAAABAI)

Question 2: why Mission Planner says there is no GPS? I have the following settings:
missionplanner040720 -Reachview: (everything like in documents)
-Mission Planner:
GPS_TYPE = 13 (ERB)
GPS_AUTO_CONFIG = 1
GPS_AUTO_SWITCH = 1
GPS_INJECT_TO = 0

SERIAL3_PROTOCOL = 5 (GPS)
SERIAL3_BAUD = 38 (38400)

GPS Injection settings as per in picture:

Mission Planner is connected to ArduRover via UDP link (no telemetry radios), 57600 baud speed. All other telemetry works okay, for example I can see IMU moves from Mission Planner data view and previously used M8N GPS worked as supposed (in the same serial3 (GPS) port).

Please help me! If any further information is needed to solve my problem, don’t hesitate to ask.

Hi @tomppavaan,

We usually recommend using Reach M+ as a second GPS module. May I ask you to connect the receiver to Serial 4/5 port as described in this ArduPilot’s guide? Please note that you’ll need to set the SERIAL4_PROTOCOL and SERIALL4_BAUD parameters in Mission Planner.

Could you please specify where you run the tests? It’s essential to provide the unit with a sky view so that it could calculate a solution.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.