Reach M+ Pixhawk 3Pro Setup

Hello everyone!

I would like to receive some help about some parameters of MP.

My first configuration with M+ is MP injecting RTK corrections into telemetry, with a base passing corrections to PC via TCP. Mission Planner shows a good satcount in this case, gives “rtk float” message for the gps and “gps status” = 5. However, checking the reachview app, the M+ doesn’t find the base position and all the points rapresented on the map are red which means no corrections. Is this fine with my configuration?

My second configuration passes corrections from base to rover via LoRa radio. In this case in the reachview app, M+ finds base position and shows green points which means fix correction. However in the MP I have a gps status = 3 and a “3D gps” message. Is this all right?

Thank you very much for your help.

Hi @mirkoshtylla,

In your first setup, Reach M+ doesn’t receive base corrections. We need more information about your settings in Mission Planner and Reach M+.

Could you please send us screenshots with MP settings (GPS_TYPE, GPS_INJECT_TO, GPS_AUTO_SWITCH)? SERIAL4_BAUD should be the same as chosen in ReachView position output. Also, a screenshot of Mission Planner main page would be great.

In regards to your second configuration, could you please provide a screenshot of the screen with a GPS status message? How many satellites does it show?

1 Like

Hi @gleb.gira, thank you for your kind response.

I’m not in the office right now so I can’t post you screenshots, sorry for that.

For the first question I followed exactly parameters written in the integration guide. So GPS_TYPE = 1, GPS_INJECT_TO = 1, GPS_AUTO_SWITCH = 1. Regarding the BAUD I tried both 38400 and 57600 changing every time all parameters together. In all these cases I always get gpsstatus2 = 5 with RTK float correction but in Reachview page I’m not able to see these corrections coming.

For the second question I see more or less 11-14 satellites. From the Reachview app I can see at least float corrections but from MP the best I get is a gpsstatus2=3 and a 3D gps fix.

Thank you very much.

Hi @mirkoshtylla,

I wanted to check if you managed to get some screenshots of your MP settings.

Is it also possible to provide us some photos of your hardware setup? How do you connect Reach M+ to Pixhawk?

Keep me updated.

Hi @gleb.gira, not yet. I’ll post everything you asked for on Monday! Thanks.

Hi @gleb.gira,
this is the screenshot of the MP flight data page. Today I didn’t get more than a 4 on gpsstatus2, probably for sky conditions but last week I managed to get a gpsstatus2 = 5 with RTK float with the same setup.

I followed precisely all the steps of this guide for the setup https://docs.emlid.com/reach/ardupilot-integration/ including baud rsate and all hardware configuration. Thanx.

Hi @mirkoshtylla,

Could you please send us simple system report for both Reach units?

Also, photos of your hardware setup would help a lot to identify the issue.

Hi @gleb.gira, I upload hardware setup photos, now I extract system reports and I post them to you.

This is the simple system report of the M+ unit:

Simple system report
app version: 2.18.1-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip: 192.168.1.27
  is_added: true
  is_connected: true
  is_visible: false
  mac_address: 6C:21:A2:3A:0F:D8
  security: wpa-psk
  ssid: JP DRONI
  uuid: 2ade8673-0bb8-45f4-a356-a43e57c568c5
base mode:
  base coordinates:
    accumulation: '2'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
  output:
    enabled: false
    format: rtcm3
    path: tcpsvr://:9000#rtcm3
    type: tcpsvr
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '0.1'
    '1010':
      enabled: true
      frequency: '1'
    '1097':
      enabled: false
      frequency: '1'
    '1107':
      enabled: false
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
camera:
  duty cycle: 20
  enable: false
  period: 2
  polarity: true
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: ttyMFD2:38400:8:n:1:off
    send position to base: 'off'
    type: serial
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
    version: null
  solution:
    format: LLH
    started: true
    version: null
lora:
  air rate: 2.6000000000000001
  frequency: 868000
  output power: 20
position output:
  output1:
    enabled: true
    format: erb
    path: ttyMFD2:38400:8:n:1:off
    type: serial
  output2:
    enabled: false
    format: llh
    path: :9001
    type: tcpsvr
  output3:
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
  output4:
    enabled: true
    format: llh_ext
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: true
    glonass: true
    gps: true
    qzss: true
    sbas: false
  snr mask: '35'
  update rate: '5'

This is the symple system report for the RS unit:

Simple system report
app version: 2.18.1-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip: 192.168.1.60
  is_added: true
  is_connected: true
  is_visible: false
  mac_address: 6C:21:A2:39:FD:0E
  security: wpa-psk
  ssid: JP DRONI
  uuid: e85a7494-202f-4217-af1b-c173ae278411
base mode:
  base coordinates:
    accumulation: '2'
    antenna offset:
      east: '0'
      north: '0'
      up: '1'
    coordinates:
    - '44.40129'
    - '8.949809'
    - '20'
    format: llh
    mode: single-and-hold
  output:
    enabled: true
    format: rtcm3
    path: tcpsvr://:9000#rtcm3
    type: tcpsvr
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '0.1'
    '1010':
      enabled: true
      frequency: '0.5'
    '1097':
      enabled: true
      frequency: '0.5'
    '1107':
      enabled: false
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
    gps:
      enabled: false
      frequency: '1'
    qzss:
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
correction input:
  input2:
    enabled: false
    format: rtcm3
    path: ttyMFD2:38400:8:n:1:off
    send position to base: 'off'
    type: serial
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
    version: null
  solution:
    format: LLH
    started: true
    version: null
lora:
  air rate: '9.11'
  frequency: 868000
  output power: '20'
position output:
  output1:
    enabled: false
    format: erb
    path: :9001
    type: tcpsvr
  output2:
    enabled: false
    format: erb
    path: :9001
    type: tcpsvr
  output3:
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
  output4:
    enabled: true
    format: llh_ext
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'on'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: static
  positioning systems:
    compass: false
    galileo: true
    glonass: true
    gps: true
    qzs: true
    qzss: false
    sbas: false
  snr mask: '35'
  update rate: '5'

Hi @mirkoshtylla,

Your settings in ReachView app are correct. I believe that this is a hardware setup issue.

May I ask you to rearrange Tallysman antenna? Reach M+ antenna is sensitive to environmental interference. It has to be placed on a ground plane made of conductive material no less than 100x100mm. It should reduce multipath and provide shielding. Also, try keeping all electronics as far as possible from the antenna.

You can read more about antenna placement requirements in the following guide.

Let me know if it helps you.