Reach M+ not recognized by Pixhawk

Hello Guys, you are my last rescue. I tested about 2 weeks now to integrate a Reach M+ Unit into an ArduCopter but it won’t get recognized. When i connect to it, it works solid but the integration to pixhawk is not working.

Basic setup:
ArduCopter 4.0.3 is connected with the official 6 to 6 Pin Cable (i plugged the 5V cable out, to power it separately) to a Cube Black. The Reach M+ (V2.22.5) is powered separately over the C2 Port. On C1 Port is the hotshoe on S1 is the official 6P Cable to GPS2 Port of Pixhawk. On S2 is the Lora Module. Base is a Reach RS+ with same Version.

I changed a lot to check if it’s working with other settings, but no change.
I already swapped the Pixhawk AND the Reach M+ unit. so it shouldn’t be a hardware problem. I already installed 2 units in other vehicles without any problems. The same Param-settings on the actual vehicle won’t work eather. I swapped baud rates but still no changes.

Here my Parameters:
GPS_Auto_Switch = 1- Use Best
Serial4_baud = 38400
Serial4_protocol = GPS

Reach M+

Correction Input
LoRa Freq. 868.0 MHz
AirData Rate 4,56kb/s
FOrmat = RTCM3

Position Output
Device = UART
Baud = 38400
Format = ERB

Hi @most,

Could you share your hardware setup photos, please?

After factory reset of the rover and base it started working.

Hey @most,

Glad you’ve solved an issue. :slight_smile:

May I ask, what do you mean under “factory reset”? Did you reset settings to default via ReachView?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.