Reach m+ extend time to look for network before it creates it's hotspot

I have Reach M+ and a Navio2 running from a raspberry pi, of course. I have added an additional USB wifi dongle that has a long range to connect with my main network. I then generated a network bridge on the raspberry pi using the internal wifi to broadcast a network local for my rover. My Reach M+ is configured to join this network and it seems to work well as long as my raspberry pi is powered up before the Reach M+. Under normal circumstances the Reach M+ is powered by the Raspberry pi and they are all powered on at the same time. This creates an issue because the network is not yet available immediately when Reach M+ boots (the RPi is booting too). Reach does not find the network and continues on to create a hotspot. I’m looking for something that would allow it to connect properly in sequential order when the system is powered on. Anyone have any ideas of how to deal with this situation?

In case someone else stumbles on this looking for help with a network bridge setup, I used create_ap --> https://github.com/oblique/create_ap. After following many guides, all of which had problems, I found create_ap and it works great!

Maybe use a systemd hook for (like requires-network) to flop the logic level on a GPIO pin and close a set of relay contacts which power up M+?

That would make sure the power up of M+ occurs only after the network is up.

1 Like

Hi @beeeeee,

Reach M+ doesn’t have features for the delayed power on, so I can’t recommend something specific.

It seems that some kind of relay may work, as @bide proposed. It shouldn’t necessarily be a network-require type. Some time based relay should fit too.

1 Like

Thanks @bide for the suggestion.

I ended up implementing something that isn’t ideal but seems to work for my case. I have a main [wifi] network that contains my DHCP server. This is almost always available when the robot starts, even if not strong. When the signal drops from this network my Reach M+ connects to the bridged local network. Seems to work okay although during the switchover the connection to my base Reach RS+ gets a little wacky. I’m thinking another solution may be able to turn off AP mode all together but this is a little risky if I run into problems.