Reach M+ Connection To Win 10 PC over USB

I have successfully connected one of my RM+ modules to a Windows 10 app over the USB to PC option in Reachview. Unfortunately the RM+ module periodically stops sending data to the port and this causes an “access denied” error on the port that latches and won’t go away until I reboot the machine. I’ve tried accessing the data output using TCP, but I always get “connection refused”. Any help would be appreciated. We are using the RM+ modules for a precision ag robot and we need absolute rock solid, reliable and predictable behavior in this machine. It seems like this unit is perfect for the job if I could just find a solid way to get the data out of the module.

What is the app you are running and what baud rate is it anticipating?

I am trying to connect with a .NET Windows app that I am writing. I have tried all of the available baud rates, which in all cases I have matched to the port settings on the hardware and the RM+ Reachview app. The problem persists regardless of baud rate settings.

Is it raising an exception on the .net side? If so, I’d catch the error, completely close the connection, and start with a fresh connection. Access denied might be because it’s still on an open connection.

1 Like

Hi Raymond,

Let’s check if Reach M+ outputs the position data correctly first. Please use PuTTY software to output data from Reach M+ to Windows via TCP.

The step-by-step actions are:

  1. Download PuTTY.exe app;
  2. Setup TCP output in ReachView;
  3. Run PuTTY app;
  4. Choose “Telnet” connection type;
  5. Specify the IP address of Reach RS unit and the port as in ReachView;
    Hit “Open”.

Please make sure the NMEA strings are transmitted evenly without any errors.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.