Reach led alway red, no ReachView interface

Hi, I’ve bought 4 Reach units and with two of them I’m in troubles.
In this post I want to ask help for the first one. I was able to correctly configure the WiFi access. Now I’m able to access that unit using ssh but I can’t see the ReacView interface on the browser. Its led is always red and I can’t understand what is wrong with it. Thanks to the ssh access I’ve issued the dmesg command and I got some errors as below:

[ 302.568938] EXT4-fs (mmcblk0p8): error count: 2
[ 302.569001] EXT4-fs (mmcblk0p8): initial error at 1476052313: __ext4_journal_start_sb:62
[ 302.569032] EXT4-fs (mmcblk0p8): last error at 1476052314: __ext4_journal_start_sb:62

furthermore looking inside the /home/reach/ReachView dir I found that is 0 size which doesn’t happen in the other units I belong.

I’ve reflashed the unit but after that operation the Reach module led is still red and no ReachView interface is available. Can someone please help me?



It seems that you’ve encountered a faulty unit. What’s probably happening is one of the self-tests fails and stops the app from running at all.

Could you try running sudo systemctl status reach-setup.service and post the output here?

Whatever happens, it’s best to contact for a replacement.

Hi Egor

I’be been lucky. After the third reflash the EMLID unit has started. Before getting the right solution, as I’m a Mac user, I’ve tried the Intel_Edison_Setup for Mac which worked for the other units but not for this unworking one. Even the terminal brocedure under Linux, Mac and Dos didn’t work. Just Intel_Edison_Setup for Window solved the problem.