Reach Firmware Update

Reach 26.2 was not working but is now after 10 days. Take whatever Emlid tells you and be thorough. Last time I was shut down for 9 days this time 10 days. First time they didn’t tell us publicly to unpair everything that has to do with bluetooth and then repair/reset all of them. Tatiana actually brought this to my attention after a week of talking to others and I was back on track.

This time, they told me all is working well… well it was not! when they can’t figure it out add common sense to what they are saying and try every angle possible. Flashing and downloading the v26.2 zip file does not work! I had to download the file directly from the flash app then all worked as before. An obvious glitch somewhere because the flash app will not open the zip file no matter how many time you try it as is or unpacked. The direct download of the 26.2 img file works.

No more updates for me in the middle of any project!

Emlid should release the img files so we have the option to revert back to the version that was working well for us. We bought these units to be productive not to be restrained by a company who has a different agenda resulting in a financial burden.

2 Likes

I only update and test one unit first regardless, beta or release.

You can also ignore an update for some time.

2 Likes

Hi @GolfMaps,

The connection with an Android device via Bluetooth can be a tricky process to configure. We understand that and always try to give the steps as detailed as possible.

Hence, the Bluetooth connection issues and hotspot connection issues are rather complicated to troubleshoot remotely. We can see the result, but we don’t know the process that leads you to it. That’s why we try to get a full view of the step-by-step actions you take: it helps us to check at what stage something goes wrong.

During our correspondence, we’ve checked many different configurations of your receiver. But, unfortunately, sometimes the information was not enough to get an understanding of what the issue is.

Still, we can conclude that the Bluetooth difficulties you’ve faced are not connected to the firmware version of Reach receiver. We can assume this as you successfully worked with previous versions and managed to establish the connection on the current one. We also see that the specific Android device doesn’t cause the issue as you’ve tested different gadgets. Furthermore, we’ve repeated your setup and configured the connection ourselves, which allowed us to confirm the possibility of such integration. Additionally, we thoroughly checked the System Reports you’ve sent. Therefore, we can see that there are no hardware issues with the Reach RS2 device.

This analysis shows us that something goes awry during the connection process. But, as I’ve mentioned, we can hardly do much without seeing the whole picture of what’s happening with the device. For that, we need to understand the exact steps of connection. This stage is where we need your cooperation.

Getting these details can be a long process. We check them thoroughly to be sure when we give you the solution. That’s why troubleshooting can take some time.

Regarding the Flasher issue, I can see from the screenshot that you use an incorrect image: this image is for Reach RS while you’re working with Reach RS2. That’s why the flashing process fails.

4 Likes

Hi Polina thanks for the reply, you should have another look it is absolutely not RS but RS2 as it should be. Now may you kindly give us another explanation?

She is referring to the .zip IMAGE file of the firmware which appears to be the root of your problem.

1 Like

That zip file was directly downloaded from the Emlid site!

She refers to me using RS… not RS2 is there visual issue here concerning my image?

Try this

https://files.emlid.com/images/reach-rs2-v26.2.zip

https://docs.emlid.com/reachrs2/reach-panel/firmware-reflashing

2 Likes

There is no issue concerning your screenshot image you provided… it’s clear as day the selected image reach-rs-v26.2.zip file was selected to attempt update… which the file is for RS… even though you selected the RS2 device. I.e. mismatch.

Have you looked into maybe using Trimble, Leica, Topcon, etc equipment and their support plans?

2 Likes

Emlid should allow the loading of an older version on our device.

Hi everyone,

Just wanted to conclude here. To avoid issues with reflashing process, the model of the unit and the image you use should match. This can be achieved if the Flash Tool downloads the image by itself: it will automatically load the latest image for the chosen receiver.

Regarding the ability to go to the previous version, let me explain this. What we’re working on is the possibility to move from the latest Beta version to the latest Stable version without the need for a reflashing process.

We don’t support going from the up-to-date Stable release to the previous Stable release. The most current stable versions contain all the fixes and improvements. That’s why we always recommend sticking to the latest releases.

If you face any issues with our devices, please, reach out to us so that we can check the behavior. You can do it here on the community forum or via support@emlid.com.

3 Likes