REACH failed on test1, test2 and update

I update the firmware V2.3 by intel edison breakout board. log show me update success.
when i put the intel edison back to REACH and first boot, the “test” failed and the update server unreachable, so REACH stuck there, how can slove this issue? hardware issue?
i tried both smart phone and laptop, the same result.

anyone can help on this? help help~

This is never a fully-satisfying response, but I had trouble for a while where my units would fail “test 2,” and turning the units off and on again usually solved the issue. Best of luck!

Hello John,

I would start by dropping the Internet Explorer. We only support Chrome(preferable) and Firefox. The app might not work in a stable fashion in IE.

thanks for your response,i tried turn the intel edision off and on for couple of times but still failed test1 and test2. should i order a new intel edision module and try again?

ok, i tried again by Chrome, but the same results, what test1 and test2 means? hardware failure?
why the server unreachable? please point out how to debug it. many thanks

Yes, Test 2 means something is wrong with internal receiver. If you have a Reach RS, hardware reboot might help. For this, hold the power button for 15 seconds. Try to power it on afterwards.

Do you have Internet connection in your network? Or, maybe, the speed is not good enough?

i only have REACH on hand.
yes,the laptop with good internet connection.
any other way to debug this issue? like ssh command to check or boot log?

i grab boot logs from usb-uart port of intel edision BB board, maybe useful for debugging.

WR: 20104000

SCU IPC: 0x800000d0 0xfffce92c

PSH miaHOB version: TNG.B0.VVBD.0000000c

microkernel built 11:24:08 Feb 5 2015

******* PSH loader *******
PCM page cache size = 192 KB
Cache Constraint = 0 Pages
Arming IPC driver …
Adding page store pool …
PagestoreAddr(IMR Start Address) = 0x04899000
pageStoreSize(IMR Size) = 0x00080000

*** Ready to receive application ***
[ 1.752755] snd_soc_sst_platform: Enter:sst_soc_probe
[ 2.226583] pmic_ccsm pmic_ccsm: Error reading battery profile from battid frmwrk
[ 2.235598] pmic_ccsm pmic_ccsm: Battery Over heat exception
[ 2.235678] pmic_ccsm pmic_ccsm: Battery0 temperature inside boundary
Application available at (physical) address 0x04819000
VRL mapped to 0xff217000
App size = 11508 bytes

    App Authentication feature is disabled!
    Resetting IPC

*** Ready to receive application ***
[FAILED] Failed to start nginx.service.
See ‘systemctl status nginx.service’ for details.
[ OK ] Started Login Service.
Starting Hostname Service…
[ OK ] Reached target Sound Card.
[ OK ] Created slice system-systemd\x2dfsck.slice.
Starting File System Check on /dev/disk/by-partlabel/home…
Starting Getty on tty1…
[ OK ] Started Getty on tty1.
[ OK ] Reached target Login Prompts.
Starting Network Name Resolution…
[ OK ] Reached target Network.
Starting Zero-configuration networking…
Starting Mosquitto - lightweight server implementati…SN protocols…
[ OK ] Started Network Name Resolution.
[ 7.053309] systemd-fsck[223]: /dev/mmcblk0p10: recovering journal
[ OK ] Started Mosquitto - lightweight server implementatio…T-SN protocols.
[ 7.083667] systemd-fsck[223]: /dev/mmcblk0p10: clean, 18/151392 files, 26805/605179 blocks
[ OK ] Started Zero-configuration networking.
[ OK ] Started File System Check on /dev/disk/by-partlabel/home.
[ OK ] Started Hostname Service.
[ OK ] Created slice system-systemd\x2drfkill.slice.
Starting Load/Save RF Kill Switch Status of rfkill2…
Starting Load/Save RF Kill Switch Status of rfkill0…
Starting Load/Save RF Kill Switch Status of rfkill1…
Mounting /home…
[ OK ] Started Load/Save RF Kill Switch Status of rfkill2.
[ OK ] Started Load/Save RF Kill Switch Status of rfkill0.
[ OK ] Started Load/Save RF Kill Switch Status of rfkill1.
[ OK ] Mounted /home.
[ OK ] Started Restore Sound Card State.
Starting PulseAudio Sound System…
[ OK ] Started Camera trigger service.
[ OK ] Started Battery monitor service for ReachRS.
[ OK ] Started ReachLED service.
Starting Emlid Reach setup…
[ OK ] Started Emlid Reach setup.
Starting Load/Save RF Kill Switch Status of rfkill3…
[ OK ] Reached target Bluetooth.
[ OK ] Started Load/Save RF Kill Switch Status of rfkill3.
[ OK ] Started PulseAudio Sound System.
[ OK ] Reached target Multi-User System.
Starting Update UTMP about System Runlevel Changes…
[ OK ] Started Update UTMP about System Runlevel Changes.

thanks again.

Just to confirm, are you booting Edison while it is mounted on a Reach circuit board? Can you post a pic of your setup?

Are you sure the connector is fully seated?

hi bide,
i put edison on intel edison break board and get the log from usb-uart port. since my reach module failed on test1 and test2 , i am trying to find what’s the root cause.
you mean the edison can not boot up independently ?

Of course the Edison can boot up on it’s own, but the ReachView software checks the peripheral hardware and would obviously fail a test if that hardware was missing. I’m pretty sure you are already aware of that.

Plus, you are probably one of the very few people who has cut off the protective heat shrink and separated the Edison from the Reach board. I can’t think of a reason why you would want to do that, unless the Reach module has already suffered some kind of damage.

well…, let me mount it back and try.
that’s because i update the V2.3 firmware by intel break board.
i will let you know the test result.



Why would you need that?

not sure, i saw your team released the V2.3 on website. so i try to reflash the REACH. not necessary?


I think when Egor said, “Why would you need that?” “That” meant the Edison breakout board. I was wondering the same thing.

The official method for firmware update is over USB, so it seems odd that you would require a breakout board. This is the kind of thing that Emlid needs for product development, but there is no reason for a user to need one, as the development is already done for you!

do you mean i can reflash REACH by USB port directly? but i follow the configuration tool step by step, it asked to put the edison on break board ??? Oops…

Well, yes. Sorry for the confusion.

We use a general purpose flash tool, that’s was not built specifically for Reach, but rather Edison - the internal engine.

We might use a tool built by Intel, but of course we would never make you disassemble something, in order to update the firmware. Of course, you can.

i am stupid…
let me try in this weekend and let you know the good news!
thank you all.

i just came back from business trip. reflah REACH seems its working except test1 fail, so what’s test1 meaning?
many thanks