Reach Ethernet (OTG cable) not working on reboot

Hello everyone! Sorry if this question has been asked before, I tried searching and didn’t find an issue like mine. Basically, what I am trying to do is have the RTKs connected to the network through the router, instead of through wifi. The reason is because the rover itwould have to operate at distances of up to 2km, so there is pretty much no way that the Reach’s wifi antenna can connect that far. The Reach on the Rover can probably connect, since the router is on the rover, but the base station one won’t be able to.

Reachview version: v2.10.0 (latest)
Detailed problem:
Now, I have gotten it all working through wireless. The base and rover RTK’s can communicate with each other through the network (and the rover RTK receives correction info). Through this setup, I could also use TCP to read the raw coordinates, which is also a necessity for automation purposes. I though that I could just “forget” the wifi networks, and use an ethernet adapter (USB OTG cable to USB to ethernet adapter, D-Link DUB-E100). It worked fine at first, but as soon as the RTK is rebooted, it keeps giving me “connection refused” errors, until I connect to the hotspot, load the GUI using, and then reconnect to my router. After that, I am able to use all the functions normally through ethernet.

Static IP is set through a router configured with DD-WRT, if it makes any difference.

Your step by step actions:
The actions that I took were rebooting the router, rebooting the Reach, trying to ssh into it (no luck), pinging it (no luck, times out). This occurs on both the Reach’s as well.

If using any additional hardware please provide exact make and model:

  • The included OTG cable and the DUB-E100 D-Link ethernet adapter.

I am not as experienced with Linux and such, but I am learning as I am going. I was thinking maybe I am having this issue is because the adapter is not it’s default network device (the WiFi adapter is), so it doesn’t accept connections through it until a connection through the default one is established, in which case all I would have to do is set the OTG adapter as default. In the future, I would also disable wireless on this altogether to save power, which I know how to do (in theory). But, I cannot do that until I am able to connect to the Reach through the ethernet adapter at all times, so`any help would be appreciated! Let me know if more information is required, and apologies if I made a mistake (such as putting it in the wrong subforum)

Edit: Turns out I was wrong, even connecting to the hotspot and navigating to gives connection refused errors. After a while, it magically starts working again, so I’m not sure what’s going on here. Connection to does bring up the WiFi page though, but that doesn’t really help me.

First, you might have a sequencing problem.

  1. The router needs some amount of time to boot and start it’s WiFi.
  2. Reach needs time to boot, and there is one short window of opportunity for it to connect to your router’s WiFi. If Reach doesn’t hear your router’s SSID broadcast in that time, then it just creates it’s own hotspot.
  3. After Reach sorts out it’s network choice (client or hotspot mode), it still needs time to finish booting and bring up ReachView and start RTKLIB and open up TCP ports, etc.

So, are you sure you are leaving enough time between all the steps?
Are you able to check your router’s SSID broadcast rate? If it is set super slow, consider speeding up the rate.

I have the DUB-E100 adapter as well, so if you are still having trouble, I don’t mind doing a test for you to see if I get the same result. Are you using the Reach module or Reach RS? If Reach module, what is your power source?

  1. Oh, I meant rebooting the RTK itself - the router remains on throughout the process.
  2. I would like to configure the RTK so that it does not create the hotspot if it can connect to the router via ethernet. Not sure if it’s possible though
  3. Ah, that might explain why it starts working magically ~5 minutes after bootup in hotspot mode. But I am not sure why it does not work directly in client (with OTG ethernet mode)

If you can test whether or not you can access the GUI through ethernet, when your wifi is turned off on your router, it’ll be great!

If not I guess I will just have to temporarily connect it to the wifi, go to the GUI and turn wifi off to get it to work with ethernet only mode.

Thanks and let me know if you need more information!

I did some testing and I confirm your claim that the USB-OTG adapter does not work on reboot. If you plug the USB-OTG in in after Reach RS is booted, then it works fine. It makes no difference if there is a USB client device plugged into the OTG adapter or not. Requesting comments from @emlid please.

I tested with these items:

  • Reach RS
  • USB-OTG adapter; Pisen (included with Reach modules)
  • USB-Ethernet adapter; D-Link DUB-E100
    • idVendor=2001, idProduct=1a02

My other equipment was:

  • Cat5e cable
  • Ethernet switch
  • Linux PC running dnsmasq with DHCP server enabled for

Here are two dmesg logs showing what happens:

  • USB-OTG and USB-Ethernet were plugged in, then Reach RS was booted:

    • 13s: USB-OTG detected
    • 13s: USB-Ethernet detected (no LED indication)
    • 15s: USB-Ethernet disconnected
    • 15s: USB-OTG disconnected
    • 214s: USB-OTG physically unplugged from Reach RS
    • 220s: USB-OTG & USB-Ethernet physically plugged into Reach RS
    • 221s: USB-OTG detected
    • 221s: USB-Ethernet detected (with LED indications)
    • 225s: Ethernet interface link up, 100Mbps, full-duplex
    • usb-otg-ethernet_2018-02-25_dmesg.log (62.3 KB)
  • USB-OTG only was plugged in, then Reach RS was booted:

    • 13s: USB-OTG detected
    • 16s: USB-OTG disconnected
    • ~300s: USB-Ethernet physically plugged into USB-OTG adapter (no LED indication, no log message)
    • 379s: USB-OTG physically unplugged from Reach RS
    • 383s: USB-OTG & USB-Ethernet physically plugged into Reach RS
    • 384s: USB-OTG detected
    • 384s: USB-Ethernet detected (with LED indications)
    • 388s: Ethernet interface link up, 100Mbps, full-duplex
    • usb-otg_only_2018-02-25_dmesg.log (58.7 KB)

Thanks a lot for going through the trouble for testing it!

Hopefully the @emlid team can shed more light on to the issue and how we could avoid it.

I don’t know much about this. Sorry!

Hey guys,

It’s really strange for this issue come up because it’s something we had to explicitly take care of during RS development. I can confirm this, although have no idea when this resurfaced. Thanks for the report, we’ll take care of this soon.

1 Like

Thanks for the update! Any ETA, so I know when to switch to the beta channel and give feedback, if needed?

Edit: By the way, I’m not sure if it makes a difference but I am using the regular Emlid Reach (2 of those)

Oh yes, it matters. Thanks for the edit.

I am not sure yet, we still need to figure out what actually goes wrong. I’ll try to release the fix in the next week or two.


Thanks a lot! Feel free to message me if you need me to do any further testing.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.