REACH does not light up

Dear REACH community

I bought a couple of REACH to achieve integration with a drone that uses PIXHAWK. I did a test in the office who seemed conclusive. But one of the REACH fails to light, I do not know why. I tried to power it by USB cable, and even taking on cable DF13 with PIXHAWK. I do not know if this is a problem maker. In this case, what should I do? Are there a guarantee that covers the purchase of the REACH? Is it possible to remove the protective plastic of the REACH without losing the guarantee (to check what 's wrong with this module, if it’s the EDISON, we can replace it) ?

Also, having only a single REACH I tried to transmit corrections by a Topcon receiver to the REACH used as ROVER . Is it possible to use a single REACH in this configuration? Mission Planner can decode the RTCM message, but seems like the REACH used as a ROVER can’t understand it. Can you explain me why ?

Thank you in advance for your answers.

Best regards,



Please contact with your order number, we will arrange a replacement for the module.

It is probably possible to use Topcon as a base, it should output RTCM. But we do no provide support for 3rd party hardware.