Reach - Disable WiFi Access Point

It appears that the WiFi Access Point starts approximately 30 seconds after boot on Reach Image v2.9.0 (and possibly other versions). How do I disable this?

I want the system to continuously scan for WiFi networks and connect when a known network is present. I have my networks configured in “/etc/wpa_supplicant/wpa_supplicant.conf”. I have a python script continuously running in the background that is checking whether the network is in Access Point mode, and if so tries to switch the WiFi to client mode. I use the wificontrol python package. Sometimes this doesn’t work, and I’m trying to determine the root cause of the issue and suspect there is other software running at the same time, conflicting with my software.

Additionally I am trying to disable wifi entirely when it is not needed by calling ‘/usr/sbin/rfkill block wifi’. This seems to sometimes work, but I have trouble calling this when called from a python script initiated with crontab.

At some point during the startup, Reach runs /usr/bin/init_network script. You are free to edit it, however a Wi-Fi related update will overwrite the script.

To disable Wi-Fi completely, you need to stop wpa_supplicant and hostapd services, then block wifi with rfkill. Not sure about the cron thing, maybe you need some special permissions for this job.

1 Like

If anyone else has this issue with crontab, I have found a solution. Add the following to the first line of your crontab file:

PATH=/usr/bin:/bin:/usr/sbin:/sbin

This allows cron to successfully call ‘rfkill’ using the ‘subprocess’ python library:

subprocess.check_output('rfkill block wlan', shell=True)

For details, refer to http://krisjordan.com/essays/timesaving-crontab-tips

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.