Reach cannot connect to my wifi network and its own hotspot connection keeps dropping


I’ve been trying to get my two Reach modules working for some time now. Currently, both modules can enter hotspot mode and I can see their data and configuration info on ReachView, but after I’ve been connected for about 15-30 seconds the connection drops and I have to cut power to the Reach and reconnect it to make the hotspot accessible again. I’ve had the Reach outside on a clear day and have seen 7-10 satellites fixing on its location in ReachView, but the connection still drops right away. I attemped to connect the Reach units to my home internet wifi, but when it says that Reach is trying to connect to another network it never shows up in the list of IP addresses that are connected to my wifi.

Once I’ve connected to the Reach unit using its hotpsot, the LED becomes solid green and then stays that color during the entire process. I’ve tried reflashing both reach units so they have the 2.3 firmware version on both. Any ideas on how I should proceed?


The WiFi built into the REACH module is not very strong and you probably want to keep the REACH module within 10-20 feet from your own WiFi router/network.

I’ve kept the wifi router within a couple feet of the Reach modules during all of my testing and it doesn’t seem to change the results.

One thing I’ve noticed since I updated my Android device is that now it will drop the current Wi-Fi connection on it’s own and then join another familiar Wi-Fi if it sees a stronger signal there. It also complains upon connecting to Reach because it can’t get to the internet, so that may also be another reason for it to disconnect and try another Wi-Fi.

It is most annoying when two Reach are powered up in nearby and if the network silently changes in the background, then ReachView will be showing the page and settings from the last connected reach along with the status display of the newly connected Reach. This means one must refresh the page often.

I would assume that there should be a setting that disallows this terrible behaviour.

Wouldnt changing Reach name make it different so it would not connect automatically?

I would also check that the phone is not trying to automatically switch between 4G/Wi-Fi.

Oh yeah, I was tricked by this as well. I just used “forget network” in my phone, so that it does not switch to the Reach that I am not currently working with. Not very elegant as you need to reenter the password, but did the job.