Reach board won't connect to wifi networks after reflashing to v2.3

Hello everyone,

I’m having serious problems trying to connect my reach board to a wifi router after reflashing to version v2.3.

The board creates a hotspot, I connect to that hospot and through reach.local I set the wifi configuration (user and key). Then I save the configuration, and select the wifi connection to connect.

At this point the board stops its own hotspot, but it does not connect to the wifi net.
Then, if I reboot the board it starts broadcasting its own wifi hospot again.

I have tried for several different wifi connections and the same problem appears.

Do you have any ideas? Would you try another version?

It might be important to mention that after reflashing I am no able to ssh the board, I assume that the version v2.3 still has user/pass reach/reach.


Hi @Eric_Guerrero

Go to Fing app on your iOS/Android, and select the same Wifi network which you configured with REACH and check if your REACH device is coming to the Fing app. “Reach will show up as ‘Murata Manufacturing’ device.”

You can also try Zenmap on “Windows” or “nmap” on Linux/OS.

NOTE: Be sure you are connected to the same wifi network which you used for REACH during configuration.
Let me know if still having issues.
I am hoping you are following this reference:


Hi @Alok_P,
I’m sure that the PC (running ubuntu 16.04), is connected to the same network.
After booting the board and setting the wifi connection it disconnects its hotspot. However, it is not able to connect to the wifi network and keeps flashing magenta and green lights.
Neither the router web or nmap list the board as a connected device. It worked with the factory default Reachview, but it seems that with the new version it gets bugged.

what i noticed is that other devices connected to the same network cause some problems (even though they normally shouldn’t)

disconnected everything from the network, maybe try a new different wifi network (maybe a hotspot from your phone?) and repeat the same steps.

What worked for me is reflashing using MAC. why did this solve my problem? i have no idea :slight_smile:

Hi @hommsy,
I tried that with my phone, and no luck.

hi, be sure, your reach is close to your wifi hotspot as much as possbile. i have encountered this before . may it can help you .

Hi @Eric_Guerrero try to reboot your router and check it.

After reflashing to version 2.4 the problem has been solved.
Thanks for your suggestions.