Reach 1.2 firmware don't start

Hi all,

I’m trying to output 2nd solution format (in XYZ) with Reach (rover side) to feed an arduino, when i’m using the Reach as gps for Pixhawk, so the first output is necessarily in ERB format.
But 2nd output is not yet available in 2.3 firmware, so i try to use the 1.2 firmware.

Problem is when i run the 1.2 image (taken from the link in the docs) the reach seems to be blocked on a state at booting
After powering Reach, color led do always this:

  • fix white
  • fix blue with red blinking
  • fix magenta (at this step windows ask me if i want to format the board)
  • off
  • fix red (staying on this state)

I use the last Intel Edison Board Configuration Tool, all flashing steps seems to be ok.
No problem flashing and running the 2.3 firmware (same way, with the Boar config tool).
Tried several times with two Reach boards.

Any idea that’s wrong?



It seems that Reach does not start up completely and the app fails. The only explanation at this point is that the flash procedure did not go through completely somehow. Can you try the command line version?

We will add support for a second solution output in the new app in the next couple of weeks.

I’ve tried the command line version but blocked at some step, don’t remember wich one, i will re-try tonight.

Good to know for the second output, impatient to use it :slight_smile:

I’ve flashed the reach by command line, but i don’t understand the board reaction when i power it with 1.2 image (look like it’s different than flashing with Edison tool).
Sometime it block on red led like i said in first post, sometime several colors appearing one by one continiously, but i can’t connect to it (no wifi hotspot created), and one time i’ve got the hotspot available and i can go thru the gui, but unable to save wifi settings, and never rebooted correctly.
Tried reboot about 10 times, waiting a moment each time to be sure the board is not not doing something…

Maybe the old 1.2 image doesn’t work properly anymore?
Anyway i don’t have much time to make my system work, so i will choose to stay with the 2.3 wich appear to be more stable, and wait for the 2nd output implementation.

Thanks Egor!