RC signal calibration

I an new to Navio2 and just start my rover with Raspberry Pi 3(with latest image from Emlid) + Navio2 + X8R receiver + Turnigy 9XR pro.
I did calibration for accelerometer sensor and compass sensor, all of them are OK. When I start RC calibration, no any green bar showed up on mission planner.
I checked the SBUS signal from X8R by oscilloscope , it looks OK.
I tried X8R in mode 1,3,4,5.

I also run " cat /sys/kernel/rcio/rcin/connected", it returns “1”.
I could see the value changes (8xx to 2xxx) by “cat /sys/kernel/rcio/rcin/ch0” when I pushed my joystick from Turnigy 9XR.
“cat /sys/kernel/rcio/status/alive” returns “1”.
“cat /sys/kernel/rcio/status/init_ok” returns “0”.
“cat /sys/kernel/rcio/status/pwn_ok” returns “1”.

Also “cat /sys/kernel/rcio/connected” returns 0". It is different with one in folder “rcio/rcin/”.

I did check all the discussions about this on the forum, but could not get any clue.

are you sure x8r is succesfully bound with your turnigy? i am using x8r with a taranis - i can see rssi strength on my transmitter to confirm successful binding;
providing enough power to navio/rpi? use a 2A usb source or a BEC to be on the safe side;
do not connect a servo when x8r is connected to navio/rpi while it is powered over usb, but can you try connecting a bec and servo to x8r to confirm it’s working?

i dont know much about sbus, (im using Jeti which is PPM only).
have you checked the arducopter wiki and forum? if the navio/rpi recognizes you receiver, then
i think the problem is caused by the arducopter software somehow, some settings maybe ?!

if you want to experiment you could use a sbus to ppm converter and see if that works
or you connect it conventional to the navio2, just to see if it works at all

sbus works out of the box with navio2; i have an x8r and the only issue i ever had was flashing a non eu firmware to it and make it connect to my non-eu taranis firmware; otherwise it would only work in d8 mode;

Hi Panky, thanks for your suggestion. The X8R works well with Turnigy 9XR. I could control a servo and a bec by X8R servo ports, not SBUS port. They should be bound well.

@Jaguar Could you please post the output of the following command:
sudo update-alternatives --display arducopter

So frustrated, but still thanks for your help. Is it possible for hardware malfunction?
Here is the display for command " sudo update-alternatives --display arducopter".

You need to select navio2 binary to make it work. Please read this doc entry carefully!

You are my hero. It works now, I made stupid mistake to think the “navio” and “navio2” are same.
Thanks you so much.