Rc Receiver and PPM Navio2 Problems

Hello all there.
I’m building my Hexacopter with Navio2+Rapsberry Pi3, i choose Mission Planner as GCS. As Rx i chase a Turnigy 9x8c(with a PPM Encoder: his -8 channels input- is connected to the 8 channels of the Rx, and the output connected to the PPM/Sbus port of the Navio2) and as Tx a Turnigy 9x Tgy.
I’‘ve already done the binding of the Rx/Tx ( the receiver displays a solid red light ) but there’s a problem : in the Mission Planner when i go for the radio calibration, if i move the Tx’ sticks nothing happened. What kind of problem could it be? I see that the light of the PPM encoder is flashing red very fast, does this mean that something’s wrong with the connection between him and the Rx? Maybe are those cables not working properly?
Maybe is the Rx broken? Maybe something wrong with the Navio2?
The string:
pi@navio:~ $ cat /sys/kernel/rcio/status/alive shows 1.
but:
pi@navio:/sys/kernel/rcio/rcin $ sudo cat ch1
0
pi@navio:/sys/kernel/rcio/rcin $ sudo cat ch2
0
channels are all 0… how can i fix also this problem?
Thanks all for the answers

Hi Alessandro,

Could you please post here hardware setup photos?

Hello there, thanks for the answer. I solved that problem, but now i have another. I can’t arm my copter with Mission Planner(using the buttons combination on my Transmitter) and when connecting the Escs to the Power Distribution Board they continue beeping costantly ( is this an error? )…on the MP interface for now it shows “ No Gps Fix”, could this be the reason?
Ty for the help

Hi @Loia94,

Have you already tried to calibrate ESCs?

Well, i’m not sure… do you have a link that explain easily and properly how to do it? Thanks…

Hi @Loia94,

Have you checked this link?

http://ardupilot.org/copter/docs/esc-calibration.html

Hello Tatiana
i did the Escs Calibration and know my drone seems to be alright.
But know i have another problem : i was changing my Gps parameters as it’s been sayin in this doc ( http://ardupilot.org/copter/docs/common-gps-blending.html ) and know i can’t connect my navio2 to mission planner anymore…there’s a MavLink problem… do u know how to reset to default these options ( i think in the Navio2 )…?
Thank You very much

@Loia94,

Great to hear the calibration helped!

May I ask you to post the screenshot with the issue?

Did you change the value of SERIAL4_PROTOCOL parameter only (neither SERIAL1_PROTOCOL or SERIAL2_PROTOCOL)?

Think the SERIAL2…

Hi @Loia94,

Please share:

  • the screenshot demonstrating the issue with connection to Mission Planner;
  • the output of sudo systemctl status arducopter command

Hi Tatiana, thanks you for the constant responding. I’ve solved that problem tomorrow by re-installing emlid raspbian on the Sd card of the Navio2/Raspberry Pi3. So i re-did calibrations from 0. Now i’m building up another drone with the same system, except for the Escs, that are Opto 30A ( my drone is DJI ). I’m in trouble with their calibration, they continue beeping as mad, and no guide is helping me. Some guides tell that they don’t require a calibration, but this beeep is preventing me to arm the drone and making him fly.
Do you know some issue?
Thanks😄

Hello,

May be a problem with your RC setting (EndPoint).

You can adjust two parameters in the MOT section:

56

Doing that, you force the throttle PWM signal between 1000 and 2000 and your DJI ESC will be happy.

Meanwhile, you should share your .param file so we could check it…

Marc

Thanks Marc, but I’ve already set this two parameters to their corresponding values ( 1000 - 2000 )… but nothing happened … something other i could try to do ?

Share your .param file,

Activate logging before arming, so we can have a log with pertinent information.

Do all the routine with the RC to arm the motors, then download and share your .bin log file.

Marc

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.