RC/Radio showing as 1 channel - Futaba T10J / S.BUS

I’m setting up my vehicle using Navio2.
I connected my Radio Futaba T10J + R3008SB to proper slot rail.
On calibration tab of GCS the Radio is shown as 1 channel only.

My setup is:

SBC: RPI3B+
FC: Navio2
RC: Tx: Futaba T10J / Rx: R3008SB RX
GCS: QGroundControl v4.0.6
SO: emlid-raspbian-20191128.img
kernel 4.19.83-emlid-v7l+
ArduPlane 4.0

Result of some checks:

root@navio:~# cat /sys/kernel/rcio/status/alive
1

root@navio:~# sudo cat /sys/kernel/rcio/rcin/ch2
1924

root@navio:~# sudo cat /sys/kernel/rcio/rcin/ch2
1154

root@navio:~# sudo cat /sys/kernel/rcio/rcin/ch2
1104

Only channel 2 changes values.

When I connect servos directly to the receiver’s channels, they react on commands from the RC transmitter!

Can anyone help me?

FYI…
I already search this and others foruns and tried all sort of recommendations about Radio Calibration, with no success.

Did you set your RX in sBus mode?


I checked with a T6K (8 channels) with R3006SB RX. Calibration screen is OK with Mission planner or QgroundControl.

Yes, already checked. R3008SB is in mode B (default) S.BUS.

Verify that cable is on the sBus out plug of the RX (Channel 8), not channel 7 or sBus2 out.

Capture d’écran 2020-05-30 à 20.12.53

Checked!

I reversed my RX to normal (not sBus) and there is no RC signal available… Incidentally, sbus2 output compatible sBus signal to the Navio2… even in no sBus mode…

I will try with my Mac and latest QGC tomorrow (W10 version is OK at home).

1 Like

sBus fine on the QGroundControl Mac version (4.0.7).

Double check sBus mode setting on the RX. You can also have a test with sBus2 out.

I’ll do the test with S.Bus 2 when I arrive home (some hours)… in Brazil now is 2:41am

Tried S.BUS2 out, unsuccessfully.
Tried to change mode (S.BUS as port 8) from B to A (disabling S.BUS) and change back to mode B (enabling S.BUS), also unsuccessfully :frowning:

I finally could calibrate the Radio!
Let me tell you guys what are happening…

I’m using UAV Cast software, for remote controlling UAV by LTE network… is a software that easy that task.
When I try to calibrate my Radio after UAV Cast installed, I can`t (the original issue from this post)…
So, I tried to reinstall the Emlid Raspbian image (emlid-raspbian-20191128.img) and setup manually all the system. So, the Radio is recognized successfully.

I think the problem is caused by any UAV Cast setup over ardupilot from Navio.
I gonna try to deal with UAV Cast support.
Thanks for all.

1 Like

Happy solution

1 Like

Thanks for help :fist_right: :fist_left: