Hi everyone, I have a problem with rc_override. The problem is that when I start override the rc channels with activated joystick the values of radio start jumping between joystick’s values and rc_override values which I set. I try to do the same with arducopter 4.0, 3.6 and arduplane 4.0 and 3.
7, with python3 dronekit and pymavlink. How can I solve it? Thanks

Hi @aganyes,

Thanks for your patience.

I’m looking into it. I’ll get back to you as soon as there’s any news.

Hi @aganyes,

Sorry it took long to get back to you.

In the ArduCopter version 3.6 and above, there’s a parameter called RC_OVERRIDE_TIME. It controls how long to keep using an override value if it hasn’t been updated. For example, when this parameter is set to 5 and the GCS has not gotten any commands to the vehicle within the last 5 seconds, the control will fall back to the RC transmitter.

There are several options for this parameter, which you can use for disabling RC overrides or timeout. You can check more details on GitHub here.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.