RC Channel Not Allowing Arming

I am unable to Arm as a result of various RC related errors. Anyone know why?

I have Navio on Pi3 with Arducopter v3.6.5 and using joystick as my radio controller.

I am doing these steps:

  1. Power Navio/Pi3 with battery
  2. From Actions > Joystick menu, map channel to controller axis.
  3. Perform Radio Calibration. Control sweep confirms the channel to controller axis is correct.
  4. Select Arm (Actions > Arm/Disarm)

Pop-up shows issue with all RC channel 1-16.

image

Thanks in advance for your help.

I was able to clear RC5 to RC16 by setting the RCx_TRIM parameter equal to RCx_MIN in MissionPlanner (Config/Tuning > Full Parameter List).

But RC1_TRIM to RC4_TRIM are controlled by joystick so I am unsure how that can corrected.

Hi @vnpathak,

What joystick model do you have?

Can you please try to manually change RC1_MIN to 1101 and RC1_MAX to 1901 (and then repeat for RC2_, RC3_ and RC4_ max/min parameters)?

Joystick is Logitech Fore3dPro.

With 1101 and 1901 values for RC1-4, it worked just fine. I think the controller is kind of flaky for these cases.

But for RC5-16, as noted, if I set RCx_TRIM to within a valid range as noted in the parameter’s description, things just work fine.

I think Mission Planner is not recognizing that these channels are not connect. I have “None” selected for the given channel in the joystick setup menu. Is there something else I need to do to tell GCS that I am not using those channels?

Hi @vnpathak,

I think you can try RCMAP feature to disable these channels in Mission Planner. I’d recommend checking Ardupilot docs for more related info.