RC Calibration

I was wondering if you could help me with my issue, so I have the same transmitter and receiver as you and i also purchased a PPM encoder. (https://www.amazon.com/gp/product/B019V59KCS/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1) the system seems to be working well but when I run mission planner and try to calibrate the radio it displays 16 RC channels and only calibrates RC 1-9 and RC 10-16 do not calibrate. The other issue is that i don’t think it sees those channels since it doesn’t show a green bar it has them in a grey color. Then when I try to arm the quad copter the mission planner displays a Prearm: 16 error.

Any idea of how i could solve this issue?

Hi Ramon,

Sorry for the delayed reply.

May I ask you to send us a screenshot of this issue?

Have you tried to set RCx_TRIM parameter equal to RCx_MIN in Full Parameter List? You should do that for every uncalibrated RC channel.

This is what I see and what I am able to calibrate once I am running the calibration. Once I end the calibration channels 1-8 will say a number between 1000 and 2000, while channels 9-16 will have a value of 0.

I tired setting the RCxTrim parameters to 1500 since at the end of the calibration it says channels not connected auto set to 1500 but that didnt help ether.

Your PPM encoder is limited to 8 channels… If you want more, you have to buy sBus receiver.

How can i change the settings on ardupilot mission controller so that there are only RC 1-8 instead of 1-16 since i am only using 8 channels?

You do not need to do that.

well if i leave it as is i get a pre-arm warning and if i turn them off and try arming the quad copter the props start running even at 0% throttle.

MOT_SPIN_ARM is set at 0.10 (default) so you know when it is in armed state. If you do nothing, it disarm after 5".

MOT_SPIN_MIN is at 0.15 (default), it is the minimum rotation speed when flying.

1 Like