Raspbian image won't boot in RPi2, checksum doesn't match

Hello all!
I just bought a new Navio2 (I’m new to it) and attached it to a working RPi2 board (I’m not new to pi).

I downloaded emlid-raspbian-20170323.img from your site and wrote it to a new micro SD card - tried to boot but it blocked on the rainbow screen with the green ACT LED flashing 7 times (usually means kernel image not found).

I tried with another SD card, same thing. Tried booting another image in case it was related to power draw, that booted fine. I then generated an MD5 checksum and compared it to the checksum in the MD5 file on your site and it doesn’t match.

I re-downloaded emlid-raspbian-20170323.img again onto two computers located on different networks and I got the same consistent checksum (different to yours).

My checksum: 41d6923d9a50a811ef67e5a523616559
Yours: efd367aa19ebeb217647816f636cabb6

I generated my checksum using both the MD5 checksum in WinZip and the windows utility fciv.
Both are consistent.

I’m using Windows10 computers. I may be doing something stupid what that might be, I don’t know.

Any help would be appreciated.

Checksum issues aside, I noticed my first error - I had plugged Navio2 into a PI model B+, not v2.
I have a RPi3 I can swap it with and I’ll try again.

Thanks for noticing this obscure checksum thing. Will look into it tomorrow.

I’m sure you’ll be fine on RPi3.


Just wanted to make sure everything’s fine on RPi3!

Thanks for your reply, I’m held up at the moment, I’ll let you know in a week or so.

Just checked - image boots fine on RPi3