Raspberry Pi/Navio, how to mount on a multicopter?

Hi guys,

how do you have your RPi/Navio combo mounted on your multicopter frames?
I cut a piece of plywood and screwed it under the RPi, then I added four blocks of doublesided foam tape (10 layers) to each corner.
The blocks stick to the upper plate of my frame.
I went outside to do an autotune, but the Althold behaved erratically and so I just flew around a bit with the standard values.
I checked the dataflash logs and had a whole lot of vibration, so I took the antivibration mount from the APM2.5 I had on this copter before and mounted the RPi/Navio on it
I did a short flight in my livingroom and it was almost the last, because I had almost no throttle control, the copter just went up and down and nearly crashed into the ceiling (stabilize mode)
While I was fighting to get it on the ground in one piece, I could see the RPi/Navio shake like mad on the antivibration mount.
I guess the RPi/Navio was just to heavy for it.
The copter has balanced T-Motor MN3110 780kV swinging balanced 11x5 Aeronaut props.
I also balanced motors and props dynamically together.
Now I am in need of some proven mounting methods. :smile:

Here are the screenshots showing the vibration graph from both tries:

Outdoor with double sided foam tape:

indoor with antivibration mount:

What are the Red, Green and Blue values on the graph ?

Those are the vibration graphs for x y (red/green) and z (blue) direction. Z is up/down, x is forward/backward (I think) and y is left/right.
The values are taken from the accelerometer and get recorded by the APM firmware during flights. The logs are to be found in /var/APM/logs/.
Have a look at copter.ardupilot.com and search for vibration.

If you want something answered, answer it yourself :smile:

I had a look at the arducopter wiki and adopted an antivibration mount listed there for the RPi/Navio combo.
Here are the results of a short hover flight indoors:

and this is the mount:

Hey Sebastian, great job!

I also tried to make a plate with dampening but rubbers turned out to be too soft and Navio+ was shaking like crazy. Finally I just hard mounted it and it works fine.

Saw your video on YouTube, looks like you already got Summer there :smile:

Oh, I totally forgot about the video. Going to add some tags and a description. It is like an on/off summer at the moment. I was lucky to catch a sunny moment, with calm winds.
Did you have a look at the vibration levels, with the Navio hard mounted?
Just to know if I wasted my time…

This sounds cool. can you tell me how you fixed the Pi to the plywood ? Any special screws or something ?

I just drilled four holes through the plywood, matching the pattern of the holes in the RPi. I used prop adapters as spacers between plywood and RPi (the black pieces you can see in the pictures) and used longer M2.5 screws to reach the standoffs provided with the NAVIO+.

Very nice.
I’m a way off needing to mount it yet but have been trying to work out best to mount the NAVIO+ / RPI to my quad.
Will check out the vid.

Here is the link to it:

it is only onboard, so it does not show the mounting etc. (it was not mounted like shown in the pictures as I took the video)

Your vibration graphs look good, better than hardmount, so time wasn’t wasted:)

Whats your quad setup @schuermannsebastian (size, batts, motors props etc)?

Any indication of flight times? The NAVIO+ / RPI combo does seem on the heavier side.



DIY Frame
T-Motor MN3110 780kV
11x5 aeronaut cam light props
4in1 20A qbrain ESC
4000mAh 4s Zippy compact Lipo
AUW with FPV gear and Gopro 3 in its case
Flying (not hovering) time is about 12min with 20-25% left directly after flight.

1 Like

I use the QBRAIN 25A ESC.

Are you powering the NAVIO+ via the power connector or letting it power from the servo rail?

Have an APM / Pixhawk power connector on order but if I can take power from the QBRAIN I might be able to get up and running sooner for some tests!



I have the powermodule and power from the ESC BEC connected. It should work with either one according to the manual.

Thanks. Think I might wait for the power module to arrive after all. No desire to see any magic smoke!




Qbrain has a 5.25V 3A BEC, it would be enough to power Navio+ and Raspberry Pi if you are not using any servos in your build.

Ok, this is driving me nuts.
I am just back from a testflight.
Autotuning with AC3.3-dev from the apm.deb was not successfull, because the copter was keeping its attitude and not returning to level flight after releasing the sticks in stabilize mode.
GPS was great with 16 sats, I never saw that before.
Here is the a screenshot:

I then compiled AC3.3-rc3 from the diydrones repository and went out to fly.
Autotune did go through all three axes and after landing and starting again, the same old problem was there again.
Flying fast forward/backward/sideways, releasing the sticks and the copter just keeps on going, perhaps returning a few degrees to level, but from 45° max to 40° or so, with sticks in the middle. I had to manually counter the attitude, like flying in rate/acro mode.
I wanted to check the values with my laptop, tried to engage PosHold mode, but nothing happened.
I landed, went to my laptop and noticed the copter had no GPS fix, not a single sat.
After restarting the APMCopter.elf I did another flight, this is the GPS log:

not really what I wanted to see, but at least it has a few sats.
The next flight, I just changed the lipo after a clean shutdown, looked like this:

Flatline again

I only flew for a few seconds, but I left the copter powered on the ground for about 5mins and still no sats at all.

The vibration log is strange, too. This is the same flight as the first GPS picture:

This is the second flight:

I changed nothing except for the lipo between the two flights, yet the vibration log seems to show two different copters.

Sebastian, this is really weird. Can you send us the logs? info@emlid.com

Here is a picture of my setup. Nothing changed in the layout between APM2.5, Navio with 16 sats and Navio with 0 sats.