Raspberry 2 realtime kernel image

% git pull
Already up-to-date.
% make clean
% export ARCH=arm 
% export CROSS_COMPILE=~/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian/bin/arm-linux-gnueabihf-
% make bcm2709_rt_defconfig
% make menuconfig

(change timer frequency to 1000hz, save, exit)

% make -j5


% ls arch/arm/boot
bootp/  compressed/  dts/  install.sh  Makefile

The Image file should be there at this point?

Here’s why you don’t have Image:

/bin/sh: bc: command not found
kernel/time/Makefile:32: recipe for target 'kernel/time/timeconst.h' failed
make[2]: *** [kernel/time/timeconst.h] Error 127
scripts/Makefile.build:402: recipe for target 'kernel/time' failed
make[1]: *** [kernel/time] Error 2
Makefile:937: recipe for target 'kernel' failed
make: *** [kernel] Error 2

You should install bc on your system (probably comes with build-essential package).

Also, do you really need periodic tick of 1000hz? Since 2.6.11 high resolution timers define the accuracy of sleeps, not jiffies - http://man7.org/linux/man-pages/man7/time.7.html


Ah, thank you so much. I should make it a habit to search the output for “command not found” :blush: bc isn’t included in Arch’s base-devel metapackage.

I was following some antiquated “Linux Audio” advice regarding the 1000hz tick. Apparently it is an issue for MIDI devices. You’re right, I probably don’t need it.


I just finalized the first test QT5+ROS on the new RPI2 with the old Navio :smile:

Is that kernel image the same running on your SD card image? It seems working very smooth :smiley:

I’ll let you know if I find any trouble.


Hi Vincenzo,

The kernel we use in an image is 3.18.9-rt5.

The graphs look pretty cool:) How does it all work? Is that an open development?

That is ROS on Navio + rqt on the base station. You can develop modules over the network once that you got a working ROS environment. I created ad-hoc ROS packet for the Navio sensor set as you can see in the figure.

I believe you would like my SD image, isn’t it?? :stuck_out_tongue_winking_eye:

I would prefer the source code:) It could be really useful for a lot of researchers.

hi @vincenzocalabro looks really cool, I am looking for an option to use ROS to extend my rover’s capabilities with computer vision for especially object avoidance.

indeed any change you can share any of your work? or some guide or documentation on how it is done?

would be really appriciated


putting ROS on a Raspberrypi can be done I have limited experience with ROS but your package to use the NAVIO sensors in ROS look intereseting, could it work together witn APM autopilot?

I am thinking about a layered system were the autopilot sets out the high level goals (waypoints) where to go and ROS would figure out the details between waypoints how to get there… handeling stuff tht is in the way etc etc…


Ehi Hugo,
I’m working in that. Soon I’ll release an image for RPi 2 with ROS and Qt5 and some of the Navio sensor modules. You should speed up your development with that :smile:

I’ll post something asap.


that would be great Vincenzo…!
Cant wait, i have ordered a RPi2 so I can run ROS stuff side by side with NAVIO


Hugo, if you want to use ROS with APM then probably MAVROS would suit you better.
It uses MAVLink to receive orientation data from the APM and can control it by setting new waypoints etc.

I am having trouble getting my RPi2 to boot with the RT image. I have tried several times formatting SD card, adding image via Win32DiskImager, then putting SD card in RPi and plugging it in. Is there a step I am missing here? I had the original Raspbian image installed from NOOBS and that worked fine.

Thanks for your help!


Did you unpack the image first?

No, I guess not. So unzip with 7Zip then write the image?

Yes, that’s a correct order.

That worked! Thanks.

Has anyone had problems with serial on the RPi2 with the realtime image?

I have a microcontroller that reads RPM and sends it to the Pi over serial using the wiringPi library. Using a RPi B/B+ and the realtime image from Emlid, everything functions as expected. When I moved to the RPi2, the serial no longer works. The oscilloscope shows both TX and RX at a steady 3.3V. The only thing I did when I moved it over to the RPi2 was recompile the code. As a test, I used the Raspbian image provided by the RaspberryPi foundation on the RPi2 and the serial works as expected, so it seems that something about the realtime image is causing the serial to not function properly.

I am successfully using serial telemetry with ArduCopter. Have not seen any issues like you describe.

I just Downloaded Raspberry pi real time image from the website. I have few questions. I see it loads to the console. does it come with any graphic interface. if so how to access it ?. Also, what is the default root password. if it can be access it. my last question is that I was trying to compile a c++ program but it was failing (using nano to write the code) it was a simple hello world c++ but when i type quotes it shows the @ symbol and when i try #include . it gives me another symbol instead of the #.
Thanks in advance.