Rangefinder Parameters

How do I go about assigning parameters for a rangefinder (I’m using HC-SR04) on the Navio2? RNGFND1_PIN and RNGFND1_STOP_PIN are giving me issues. I’ve seen this page, but it is specific for the PixHawk.

I’d like to use the servo output rail pins, any channel 5-14. I’ve adjusted BRD_PWM_COUNT accordingly, but the options for parameter values in MissionPlanner seem to be for the PixHawk. How do I fix this?


I’ve seen other similar (if not identical) closed topics on here but none of them answer the question.

Thanks!

Hi Ethan,

What’s your connection scheme of HC-SR04 with Navio2?

Can you please specify in more detail what issues those parameters induce?