Radio control not detected on Navio 2

My Navio2 seems to be working great except that the PPM/SBUS and PWM don’t seem to function. I’m using a Futaba T6K transmitter and associated R3006SB receiver, they successfully link. Just the SBUS connection from the receiver is plugged into the Navio2 PPM/SBUS header, no other channels are plugged into the PWM headers as shown in the Navio2 documentation. When I try to do a radio calibration in APM Planner 2 it comes up with the message that the radio is not active.

I’ve also tried with channels 1-4 on the receiver plugged into headers 1-4 on the Navio, this does not produce the radio is not active all the time and will occasionally allow me to calibrate it, however any movements on the controller do not correspond with what comes up on screen, and vice versa.

I’ve tried using different ground station apps like QGC and mission planner but it makes no difference. I’ve tried refreshing the parameters in APM planner too.

The Navio is powered via USB at the moment, it is connected to my laptop using a 433MHz 3DR Telemetry kit. It’s running the latest image of the modified Raspbian and its version of arduplane is up to date.

Thanks in advance

Could you please run the following in the terminal and post its output:
cat /sys/kernel/rcio/status/alive

I’ve also tried with channels 1-4 on the receiver plugged into headers 1-4 on the Navio

Do I understand correctly that you plugged RC outputs 1-4 from the receiver into RC outputs 1-4 on Navio2?

The output is 1.

Yes that would be correct.

There is no point in doing that as RC outputs on Navio2 only work as outputs.
Could you please make a photo showing how receiver is connected to Navio2?

Do these help?

navio’s pwm/servo rail is not being powered from navio’s/rpi’s usb - you need to power it from an external 5v power source (e.g. ubec);
also you connected your servos to the upper channels (ch14); channel 1 starts at the other side - next to your receiver;
your receiver should still be recognized by ardupilot/your gcs;
are you sure your receiver is succesfully bound with your transmitter?

1 Like

Ah ok. I assumed that I would be able to plug them in anywhere and it would work, so put them at the end for tidiness.

Yes the receiver is successfully bound.

Could it be that I need a SBUS to PPM converter between the receiver and Navio2?

navio2 supports sbus, no need to convert to ppm;
you might need to activate your sbus port on your receiver

How would I go about doing that?

here is the manual

Tried both modes, neither worked.

Hello, guys!

Could you please post the output of cat /sys/kernel/rcio/rcin/ch2 and move throttle stick up and down to make sure RCIO processes data? And also Could you please post the output of sudo update-alternatives --display arducopter? We need to verify that navio2 binary is selected.

It should be something like this in case of a quadcopter:

Mind the navio2 in the link!

Good day,

Greetings from South Africa. I would like some help. I have a Navio 2 connected to Raspberry pi 3, The Navio is working and connected to mission planner with no errors. I am using a Spektrum DX6 i that is successfully bound to my Orange 9 channel DSM2 reciever (S bus) capable (tested with a test servo). The Orange receiver is plugged into the PPM/SBUS input on the Navio2 but I dont get any response on the radio calibration. I can move the sticks untill the cows come home but nothing is indicated on the screen to say that the Navio is picking up the receiver. if any one knows what i am dong wrong please send some advice.


@Diablo Hi! Did you check that you selected binary for Navio2 not Navio+? What is the output of the following?
sudo update-alternatives --display arducopter


Thanks for your reply, I have forwarded your reply to my request to my friend who is the programmer. I will wait for him to respond and let you know. Thanks again for your reply. Kind regards Brent

So looking at sudo update-alternatives --display arducopter I see my link is pointed to the Navio not the Navio2, How do I change that to point to the navio2 ?

Hi Ron,

Take a look at this docs entry:

Excellent, Thank you