Question about servo gimbal

Hello,

just a quick question.

I would like to place a servo gimbal on my quadcopter… As far as i know servo gimbal does not need a separate gimbal controller like storm32 but they can be controlled by navio2… correct ??

Will navio be able also to always auto level the camera so that it always heads straight no matter what movements the copter is making ??? Or the purpose of servo gimbal that is controlled by navio, is to only allow user to move camera using the RC radio sticks ???

In the first case, will the gimbal be able to stay auto leveled using the IMU of navio ??

Thank you

Hi,

Ardupilot allows for stabilisation and/or manual control for tilt, pan and roll. You can also control the gimbal with Missionplanner or in Auto missions.
Consider buying a brushless gimbal. They are not that expensive anymore and trying to find good servos for a gimbal might even cost you more than a ready to go brushless gimbal. And a servo gimbal will never be as smooth as a brushless one.

thanks for the answer…
I do know the advantages of brushless gimbal as i already have one… However i wanted to test servo gimbal as well for a very lightweight structure…
I have never used servos in the past but i have managed to connect a servo on navio2 and be able to control it either through mission planner (from servo tab using Low High Toggle buttons) but also through my RC radio device by twisting knob CH6… I followed this page to make the servo work… —> http://ardupilot.org/copter/docs/common-servo.html
Particularly, i gave power from BEC to Navio2 and then connected the three cables of the servo to RC9 of navio2…
THen in mission planner in full parameter list i set RC9_FUNCTION=56 so that I can control the servo from the knob CH6 of my RC radio device…

However, i have problem making this servo following stabilization from navio2 (I followed this guide —> http://ardupilot.org/copter/docs/common-camera-gimbal.html#common-camera-gimbal) … So i left the BEC and servo cables connected as before and in mission planner i went to Option Hardware>Gimbal … I set Type=Servo, Tilt=RC9 , activated Stabilization option and also RC_Input=CH6… When i set those parameters I noticed that in Full Parameters list, the RC9_FUNCTION parameter switched to 0 automatically from 56 value…
The result is that the servo does not make any stabilization movements while im moving the copter and also i cant control the servo using the CH6 knob of my RC radio… why does this happen ?? Am i doing something completely wrong ??

THanks a lot

i finally fixed it… i followed the same procedure as described but i used qgroundcontrol and worked as expected… mission planner interface is very bad… and i dont know why it didnt work with it…

Sorry. I missed your reply. You are right, sometimes MissionPlanner does not set all values you enter in the GUI part. You always should control all settings in the full parameter list.

No problem,

anyway since a few days ago every time i open mission planner, a pop up window appears asking if i would like to update ardupilot to v3.5…I always close the window without proceeding to update…
Is it recommended to update ardupilot through mission planner ?? or should we only update through the sudo apt-get update && sudo apt-get dist-upgrade command ???
I have tried this command, it updated everything but still when i connect to GCS, my ardupilot version is v.3.4.6 … Why ?

Sure, you can try out the latest release by getting it from here. And then launch as described over here. Hope it helps.

We’ll update our repos soon and then you’ll just type sudo apt-get update && sudo apt-get dist-upgrade and you’ll be offered a new ArduCopter-3.5.

ok thank you… I ll probably wait for you to update the repository… I find much more easier…

Regards,

Hello,

did you finally update your repositories ?? If not, do you plan to do it soon ??

thanks

@drone_newbie the repo should be updated during next week.