QUADCOPTER -> configuration problem

Hello everyone,

I’m writing to you regarding some problems with my quadcopter.

Quadcopter content - Navio2 with Raspberry PI4 B, and the receiver is a FSI6A

with PPM signal.
I have configured my quadcopter by running the ardupilot from navio2 and set the telemetry and followed the steps with Mission Planner for mandatory hardware. Everything worked fine, but when i’m trying to arm my drone to test it for a fly, i see that the esc don’t send any commands to the motors in order to start spinning. Perhaps the esc are not calibrated or receiver doesn’t work as a PPM module in this case i have used only one wire from receiver to navio by using the PPM benefits.

command in navio2
sudo start arducopter


Capture4

I will be very grateful and i will appreciate any help and suggestion about this.

Hello,

As your receiver is ibus/sbus compatible, use the feature. (ibus servo plug)

In mission planner Full Parameter tree, check RC xx and verify default RC xx Max and Min are 1900 and 1100. Check also RC xx Trim around 1500 for all unused channels.

RC3 (Throttle) Trim is also RC3 Min

Marc

2 Likes

I have followed your advice and i have set the parameters for rc. I see that i can arm my drone for mission planner -> action -> arm/disarm and is working. The problem which i see is that one motor don’t spin just 3 of them and also i see that the quadcopter can be armed with the RC-Controller but still if i increase the throtle up motors runs faster.

Which issue could cause this?

To mention that i tried to calibrate esc within one shot unplug and plug the battery with the throttle down, unfortunately unsuccesfully.

Hi George,

Could you please provide us with more details on which calibration step you faced an issue? Did you follow this guide?