QGroundControl RC Calibration not working

Hi everyone

I’m blocked with the Radio Setup in QGC. I’m using a radio FS-I6X and receiver FS-IA6B connected to NAVIO2+RP3A+.

I’ve enabled the PPM on the TX and by running the NAVIO2 tests in python, I can see the values changing when I move the sticks up and down in the range 1000 to 2000 … but on QGC when I start the calibration, I only see changes on channel 5 and 6 that are the rotary knob. For Throttle, Pitch, Yaw, Roll, no chances! so I can’t complete the calibration procedure …

Any idea why this is happening? Maybe a parameter on QGC I need to change?

Thanks :blush:

Hi,

PPM? Use the iBus servo out and came back with the result.

58

As far as I know the NAVIO2 supports PPM or SBUS … not the iBus
What I’m doing right now is to connect the very first 3-pins output of the navio2 with the PPM/CH1 channel of the FS-IA6B Receiver. One wire for ground, one for 5V and the third (the upper one) for the signal … No other cables in between Receiver and Navio 2 except those 3 wires. And it works because via the NAVIO2 python tests I can actually read the movements of the sticks … but not with QGC. Any other ideas? thanks : )

No idea. If python test is working, it also should work with QGC.

iBus = sBus is better than PPM (latency). Change the Tx settings and move the plug on the Rx then try it.

Thanks Marc for your reply but I don’t understand how to make it work …

  • changing the TX setting is something I can do easily
  • Moving the plug on the Rx: to where? With iBus there are the 2 plugs perpendicular to the others (depicted in green) one says SENS the other SERVO. Should I use one of them? please can explicit more? and what about the NAVIO2 side?

No change on the Navio side, and Servo iBus plug on the receiver.

thank you! I’ll try this as well asap …
In the mean time I solved the problem why QGC doesn’t recognize the PPM … very stupid reason behind … I had the virtual joystick enabled and that prevented the REAL radio to be read. Now it works perfectly and I calibrated successfully!
Thanks a lot for your time and hints : )

Happy for you!

Have a try at iBus and report your feedback. If iBus is working, you will have 10 channels instead of 8 (PPM).