QGroundControl Fails to Open in Windows 10

  1. All versions of QGC newer than 3.0.2 (3.1.0 and beyond, including current v3.2.4-edge-2.2 custom release for the Edge). I personally downloaded, installed and tested every version available of QGC and identified 3.1.0 as the nexus of the issue.
  2. Installation of the QGC program runs successfully, but the program fails to open in any of Normal, GPU Compatibility or GPU Safe Mode). User is prompted by security measures to allow the program to run, but nothing materialises after confirming the program.
  3. DISABLE or UNINSTALL any integrated cameras through the “Device Manager”
  4. N/A
  5. Considering the Edge custom QGC is only compatible with Windows 10, tablets and laptops are required to run a ground control unit in the field. I have the custom version installed on my desktop and laptop (for desk connections) and a Lenovo Miix 3 tablet (for field work) and the issue arose on the tablet only.

I supported the issue reported by another user over on Github so the developers of QGC could assess the situation. Thankfully they got to the root of the issue and issued a temporary (or permanent!) fix by disabling internal imaging devices. I have posted it here on the Emlid Forums to advise any and all who may experience this issue in the future - and also to let the Emlid team know that a future stable release of QGC with fix included would be a good one to build future updates of their custom QGC version around given the Edge version is only supported on Windows 10 and the hardware options available for field work lean towards portable devices which may continue to run into this issue.

1 Like


QGC for Edge v.3.2.4-edge-2.2 is fine on my W10 (latest version) PC (Core2Quad…) and my SurfaceBook W10-i7. Former versions also.

Application start is slow…


Hi Marc!

As I stated, application runs fine on both my desktop (Ryzen 1700X) and Toshiba Laptop (i7). It isn’t necesarily a wide spread incompatibility issue and nor did I claim it to be.

If however you read through the Github post you’d find it was not a slow program open process. Having debugged with the developers and disabled the hardware, it indeed took much longer to open on my Lenovo tablet than on my desktop or laptop - point being it wouldn’t open at all previous to the hardware conflict resolution.

I simply thought it worth posting considering that I assume the preffered mode of running QGC for an Edge would be through smaller or older devices which are better suited for field work than our fancy desktops and laptops and those are the devices which appear to be prone to this issue.


Thank you, guys! We’ll try to incorporate the fix as soon as possible.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.