Python 2.7 End of life announced


Python 2.7 End of life announced. any plans to make all dependencies python 3.5+ ?

Reason i ask is emlidtool seems broken, have manually installed sudo pip install 'six==1.10.0 but still getting below.

sudo emlidtool ardupilot
Traceback (most recent call last):
File “/usr/local/bin/emlidtool”, line 11, in
File “/usr/local/lib/python3.5/dist-packages/emlid/”, line 353, in main
File “/usr/local/lib/python3.5/dist-packages/emlid/”, line 258, in parse_args
getattr(self, args.command)()
File “/usr/local/lib/python3.5/dist-packages/emlid/”, line 286, in ardupilot
self.func(ardupilot, args)
File “/usr/local/lib/python3.5/dist-packages/emlid/”, line 331, in func
File “/usr/local/lib/python3.5/dist-packages/emlid/util/”, line 37, in wrapped
return fn(*args, **kwargs)
File “/usr/local/lib/python3.5/dist-packages/emlid/”, line 51, in do_ardupilot
main_window = MainWindow(rcio_update)
File “/usr/local/lib/python3.5/dist-packages/emlid/ui/”, line 455, in init
self._info_widget = InfoWidget()
File “/usr/local/lib/python3.5/dist-packages/emlid/ui/”, line 54, in init
self._emlidtool_version = Emlidtool.get_version()
File “/usr/local/lib/python3.5/dist-packages/emlid/ui/”, line 45, in get_version
version = pkg_resources.require(“emlidtool”)[0].version
File “/usr/lib/python3/dist-packages/pkg_resources/”, line 963, in require
needed = self.resolve(parse_requirements(requirements))
File “/usr/lib/python3/dist-packages/pkg_resources/”, line 854, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (six 1.12.0 (/usr/lib/python3/dist-packages), Requirement.parse(‘six==1.10.0’), {‘emlidtool’})

Hi @sundru,

May I ask you to specify whether you use our current raspbian image?

I have the previous one, i cannot update image unfortunately.

Hi @sundru,

There are 2 ways you can resolve the issue.

The easiest one is to reflash the SD card. You can follow this guide to accomplish it.
However, in that case, all the data and configurations will be erased.

As an alternative, you can try to reinstall the six package: remove six 1.12.0 and install six 1.10.0. It’s a more complicated solution as there may appear further dependencies to install.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.