PX4Flow - I2C works, but Mission Planner does not see it

Running Linux navio 4.14.95-emlid-v7+

I just connected a PX4Flow to the I2C ports on the Navio 2 and I confirmed I can see it when scanning i2c bus.

pi@navio:~ $ i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – -- – -- – -- – -- – -- – -- –
10: – -- – -- – -- – -- – -- – -- – -- – --
20: – -- – -- – -- – -- – -- – -- – -- – --
30: – -- – -- – -- – -- – -- – -- – -- – --
40: – -- 42 – -- – -- – -- – -- – -- – -- –
50: – -- – -- – -- – -- – -- – -- – -- – --
60: – -- – -- – -- – -- – -- – -- – -- – --
70: – -- – -- – -- – 77

I installed the new firmware as per the wiki (http://ardupilot.org/copter/docs/common-px4flow-overview.html) and have re-attached the PX4flow to the Navio2 board.

I have enabled the sensor [FLOW_ENABLE] however my opt_m_x, opt_m_y and an opt_qua values are all ZERO.

Any thoughts on how to proceed?

Hi Tommy,

Have you tried to calibrate the sensor as described in the guide you’ve shared?

Yes, I did do the sensor calibration and it appeared to work well. The lens is focused to about 1m. However, the unit is still not working.

Do I need to specify the I2C address somewhere? Also, I am using the PX4Flow Smart Camera which does not have an onboard sonar sensor. I have added a UART TFMini to my UART port, which is providing elevation data.

1 Like

Hi Tommy,

It seems PX4FLOW camera can work at 400KHz I2C baud rate max.

I’d recommend trying to lower the i2c_baudrate parameter in /boot/config.txt to 400000. Please let me know if it helps.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.