PWM/ESC problem Navio2


Tried to connect a couple of ESC’s today and ended up burning all four of them. (Still cant get why they burned).

Two of the four ESC’s where connected to motors and the last two wasn’t.
I even had the bad luck of burning one of the motors.

I’m now in the process trying to find out what the cause of this is.

Here is a description of the system:
1 Navio2 & Raspberry Pi 3.

  • Linux navio 4.9.45-94f47ec-emlid-v7+ #4 SMP PREEMPT Wed Aug 30 18:17:43 MSK 2017 armv7l GNU/Linux
  • emlidtool version: 1.0.3
  • Test output (Connected to USB voltage during test):
    WARNING Please check board voltage (4.215V)!
    INFO pwm: Passed
    INFO lsm9ds1: Passed
    INFO ms5611: Passed
    INFO rcio_status_alive: Passed
    ERROR adc: Failed – Reason: Tramp
    INFO mpu9250: Passed
    INFO gps: Passed
    – Edit –
    (With battery connected instead)
    INFO adc: Passed
    INFO gps: Passed
    INFO mpu9250: Passed
    INFO pwm: Passed
    INFO ms5611: Passed
    INFO lsm9ds1: Passed
    INFO rcio_status_alive: Passed

4 ESC 30A 2s-4s with built-in BECs Output 5v 2A
2 650KV motors
1 2200mAh 4s LIPO

Only kept the middle wire in one of the four ESC’s.
** EDIT **
As a friend pointed out to me, something that might be of interest is that the ESC with the BEC connected was the one that had a motor burning as well.

It only took about 2seconds for all of them to release the grey magic smoke.

I have checked that the ESC positive and negative was properly connected to the power distribution board.
I checked that GND was connected to the lower row and “signal” was the upper row. BEC output was disconnected as I mentioned earlier.

Will upload pictures of the gear and how the ESC were connected to the power supply board

14.8V LIPO battery 4S type:

Just an overview with battery connected to the board. At the time of the incident the battery was connected to the Navio2 power supply module and the other end connected to the black and yellow cable:

Picture showing incoming power and how the ESC + was connected to the marked + (Note that I cut the cables after the incident)
You are able to see a remaining piece of the positive lead still fastened with solder:

If I understand this correctly signal upper row and GND on the bottom:

Volt measurement confirming correctness in polarity (unless I got a seg fault in the brain):

Picture showing connector to power supply board:

The mass grave:

I downloaded the “driver” and Python coding example trying to control the PWM outputs to check with a voltmeter what I get on the outputs.

When setting PWM_OUTPUT to 0,1,2,3 or 4 I noticed that all of them gets activated and outputs a signal noticeable by my voltmeter. If I set PWM_OUTPUT to 10, output 9 also gets activated but not 11.
Is this normal?

Anyone with recommendations on ESC’s that is known to work well?

Just to clarify, this post contains 3 questions:

  1. Any ideas to why my motor and 4 ESC’s went up in smoke? (Will add pictures shortly to help clarify)
  2. The PWM-outputs is behaving oddly, is this normal?
  3. ESC hardware recommendations?

From the responses I got to this question, much is pointing towards the ESC being faulty.
Possibly faulty firmware.
Lesson learned is to not have a motor connected when trying unknown ESC’s.

Could you please provide a photo of your setup? And a detailed photo of the powerdistribution?
At the moment I can not even guess, what might have caused that.

Absolutely, but not sure how much more info you will get out of it. Would be surprised if + means - in the ESC world.

I can only make a “crime scene” reenactment. Didnt see the point in keep ESC soldered to the board if they are going to burn.
Will post picture when I arrive home from work.

Pictures added.

Would really appreciate if any of the Emlid/Navio2 staff could give an comment to this.


I just burned one motor and some ESC with the same label with a Naze 32 after updating BLHeli firmware. I plugged the battery and “Poof” magic smoke.

I do not think it is Navio related.


hello thanks for the response mlebret.
The ESC’s in the picture was connected as original delivered from seller.

I dont think so either, but as the bad guy in the movie “Under Siege 2” states - “Assumption is the mother of all fuck ups” and I would really like a second opinion of the observations that I made, just to make sure that Steven Seagal doesn’t fuck up another 4 ESC’s and motors :slight_smile:

The most probable cause would of been me connecting the power on the wrong leads, but all my checks tells me it is correctly connected

I would say the ESCs were flashed with the wrong firmware, too. Best outcome is the ESC is bricked, worst outcome is all lipo power goes through the ESC and out through two motor wires unregulated and poof.
Where did you buy the ESCs? Did you buy the copter as a bundle?

1 Like

One question: did you update Navio2 RCIO after installing latest Stretch Emlid software?

If you have a Navio2 with old RCIO, there was a problem with PWM output.


1 Like

But this would not cause the ESCs to go byebye.

I did a emlidtool rcio update I think… Not sure about the correct command out of the head, I think that was the args, tried to do that initially with original software from the image, but someone managed to get unicode/ascii codec problem in

So I did a full software update/upgrade with apt, and after that made an RCIO update.

But Im a little bit unsure if I made my measurements after or before the updates. I think I did it after, but now I must recheck :slight_smile:

schuermannsebastian I agree with you, at most it would just create trouble with the signal? But it might explain the odd behavior from the PWM.

I have bought all the parts individually and from Ebay ( So perhaps that was the real mistake )
Contacted seller and asked if the specifications on the ESC really was correct, he followed up with a request to me taking pictures and now he is offering me a refund.

About to do an order from Hobby king ( I think that was the name ). So hopefully the wont be any more issues about quality -

Thanks for your feedback guys!
By the way, I cant find any pinout description for the servo-rail. At the moment my assumption (after measurements) is that the upper pin is signal and the bottom pin is ground, but where can I find this documented?

Just think about all ground pins being connected together and the signal pins need to go to the rcio coprocessor pins. So it makes sense to have the ground pins on the outside of the board and the signal pins at the inside.
Shorter ways and no barrier formed by the interconnected ground pins. And the power pin is always in the middle, so nothing bad happens if you connect the plug the wrong way around.

1 Like

This topic was automatically closed after 100 days. New replies are no longer allowed.