Product: Seems like you booted without Navio properly screwed! Error

I am getting an error that my navio isn’t screwed in properly, when it is. I noticed this after I tried to do the initial set up by using the command sudo emlidtool ardupilot. How can I fix this and get my ardupilot working? In the setup I also chose arducopter.

This is my output of my from emlidtool:

emlidtool version: 1.0.8
Vendor: ¯_(ツ)_/¯ Unknown, but most likely Emlid
Product: Seems like you booted without Navio properly screwed!
Issue: Emlid 2020-09-22 716f472abba15f9ec2b6fc51f498538e3c041d42
Kernel: 4.19.127-emlid-v7+
RCIO firmware: 0x0
emlidtool -h to get more help

Hardware:
Navio2
Raspberry Pi 3 Model B

Picture of Set-Up:

Edit adding more pictures

Additional hardware:

  • I lost the 40 pin extender and had to buy some extra ones online.
  • Not sure if it matters but I’m using a FrSky Taranis plus ACCST 2.4Ghz and FrSky D4-II 4 channel receiver I have paired them.

Note:
I’m an incredible noob at this, so an explanation in layman’s terms would be appreciated, thank you!

Hi Kabilan,

Thanks for the detailed description!

Do I get it right that this issue with Navio2 appeared when you replaced the pin extender on RPi?

This is actually my first time trying to set it up, didn’t try it before with the extenders that came with it.

Hi,

a) would check if any of the pins are bent and not inserted correctly
b) not 100% sure about Navio, but some extension Hats require a connection through the mounting screws. (believe in order to ground Hat and reduce risk of RF interference). So as you can see in the photo under the mounting screws are some gold / bronze coloured circles. Make sure they are clean and screw heads are in direct contact. - Especially underneath.
c) Can’t see in your photo: Have you got the bronze coloured extension pieces installed and are they making direct contact?

Navio2 + pi

If that is all good then obviously the problem relates to your 20 pin extender.

Hope this helps
Karl

1 Like

I added extra views of my Navio2 to my original post, the bronze coloured extension pieces are making solid contact. There’s also screws on the bottom. I made sure they are screwed firmly, I can redo this again to be sure. Do you have any recommendations on where to get good quality 40 pin extenders?

There are various places where you can get those in all shapes and sizes.
…depends where you are in the world.

I.e.

or use their worldwide website to find best location for you:

But dealing with electronic equipment on daily basis I can tell you that sometimes it’s just a bit of dirt, grease or other contaminant causing the problem.
In the electronic industry they use something like Isopropyl alcohol which removes a lot of residue without affecting components. This is often found in households as disinfectant and rubbing alcohol. - Needles to say don’t use on hole board, just on 40 pin header after removing it.
If you are careful you could also use Metho just on the contact pins - Not on anything else.

I live in Canada, tried looking on the Canadian site couldn’t find any. Luckily I bought extra I will the other ones out. If this does not work is there anything else that could be an issue?

If any of the two boards been dropped you could have a hairline crack somewhere.
Would have a good look at the board if there are any small cracks visible

Another frequent thing to happen is a bad solder joint. If you see a solder spot that looks different than others it could indicate a soldering issue causing a bad contact.

There are extenders of really different quality on the market. Some have really thin pins that fail to make proper contact with Navio. Changing the extender would be the first thing to try.

Hmm I will look into this, how would you even go about fixing a hairline crack? I guess it depends where it happened.

Yup, I ordered more extenders from a different supplier hopefully this works out.

1 Like

Igor is correct.
There are some real bad ones out there.
However, if there is a hairline crack you most likely would have to replace board as with the effects of heat, vibrations and other impact on board may cause a in flight failure if it was just patched up.

I see that sucks -_-, I want to try all possible angles to fix this. Is there even a minor chance this could be a software issue as well?

Clearly not a software issue as everyone else would have to same problem if that was the case.
If you have any doubts in regards to software just re-install the software again.
I had it happen that after software was working fine an update or something else messed with the system and then suddenly drone didn’t respond anymore as expected. - So I’ve re-installed it and it was working fine again.

But the fact that the system told you about a possible connection problem is a sign that everything in the software is working as expected. - Or else wouldn’t provided that message.

I guess you’ve tried to remove it, clean it and re-install the 40 pin header? …perhaps turn the header around.

I re-installed a new set of pin headers but the quality did seem a bit off. I’ve ordered better quality ones (I hope) so hopefully they’ll work!

The original extender that is shipped with Navio 2 is made by Samtec, you can buy it here: https://www.toby.co.uk/board-to-board-pcb-connectors/254mm-sockets/ref-raspberry-pi-rpi-hat-specification-connector-extended-tail-sockets/REF-182683-02/

It was an extender issue, I tried it with a different one and it worked but the plastic height was too big - didn’t allow for me to screw in the board. I bought long pin extenders and they gave me problems again. The extender you posted have a really expensive shipping cost, I live in Canada -_-. Will have to keep looking around.