Processing Float Points for Accurate XYZ

Hey all,

We just started using two Emlid Reach RS as Base and Rover. We forgot to change setting to “FIX” and recorded all GCPs as “FLOAT.” I tried using the post processing in the link below but it’s not working. Is that link what I need to follow for getting the points we need? If not, what options do I have? We cant go back and resurvey because after the last point, wind blew over the tripod and the reach base station broke.

Any help would be greatly appreciated. I’ve been trying to figure out some of this stuff over the forums but nothing I’m trying is working. I’ve attached the raw logs from the rover.datafiles (1).zip (5.4 MB)

Should be possible yes, Setup i used

But you need to convert .UBX and RTCM3 files before postprocessing

Hello TB_rtk!
I am new in RTK LIb processing. I tried to repeat the process you have shown. but i cannot get result as same as you… can you provide step by step solution? Thanks.

This should explain it

1 Like

@TB_RTK thanks for your help. I was able to process and get the same results you did. One more question - now that I have the plot, how can I get the precise GCP coordinates/elevations?

I can see the approximate locations in the plot and try to estimate, but is there a more accurate way of obtaining them?

@bide had a greate explenation for this. He used survey and logged the time a point was survey and then looked up the same time in the process log and extract it.

Interesting, @bide would you mind providing the steps on this? Do you have to manually log the time or is in the data somewhere? I can see the timestamp in the raw data but not the timestamp associated with each survey point.

Here is one. But i dont recall having seen it detailed step.
Edit: baby steps :slight_smile:

1 Like

ReachView can’t magically know that you are on a GCP, so I can’t answer that question until you tell me what data you collected for each GCP.

  • Did you start a survey project in ReachView and do a point collection for each GCP?
  • Did you write down the start and stop time at each point?
  • Did you start and stop the log file at each GCP?

Haha yes, baby steps indeed.

  1. Yes, point collection for each GCP. But did Float instead of Fix which is why I’m in this predicament.
  2. No
  3. Yes

I’ve attached a screenshot of the project. The black is the total log, with the red circles surrounding the GCPs (where the black dots are clustered). The green are the result of the “point collection” in the reachview app when were were on top of the GCPs - although clearly they are not in the location of the GCPs.

Just download the survey project as a .csv file. Then open it and jot down the start and stop times for each point. Back in RTKPLOT, enable statistics in the options, and also set the start and stop times to restrict the view (and the statistics) to only the time you were on a point. Then repeat for each of your points.

Unfortunately there are no times in the csv file (or other formats).

Then you must have done your survey with an older version of ReachView. It has been a feature in the stable version for a month now:

Are you sure that GeoJSON doesn’t contain those start and stop times? If not, then you’ll just have to do it visually with RTKPLOT. Click the bullseye icon to let you select a specific point in your plot. Click over one of your survey points. Then switch views from ground track to position where you see the three graphs (lat, long, height). There it is easy to see where you were stationary on a point because it is a timeline view. Just slide the selected point to the start of a point and write down the time. Then slide it to the end of a point and write down the time. Then limit the view to with the start and stop times. Then write down the average coordinate from the statistics info in the top right corner of RTKPLOT. Do that for each point.

If you haven’t upgraded ReachView, then do so. That way you will get the start and stop times in your survey project CSV file next time and doing this will be a lot easier.

1 Like

Will do, thanks so much for the help!

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.