Problems with the IMU and the examples (Navio2)

I’m new with Navio and I’ve just bought it for a University
project about the programming of an autonomous quad. But I’ve been having problems since the
beginning. Specially with the IMU. I’ve followed the first steps on the
documentation and I’ve tried some of the first examples that are on the
documentation and the only that seems to work is the LED (C++ version, but not
the python). If I run the AccelGyroMag with C++, it just says sensor not
enabled. If I run it with Python it says Connection
established: False and all the values are set to 0. The GPS examples don’t
work either (Ublox test not passed, Abort
program!). Does anyone know what I could have been doing wrong?
thank you

Hi Marti,

Python examples will be updated in the next few days, currently they do not work. Your issue looks like you are using Raspberry Pi 1, which we do not support for Navio2 currently. Can you post a picture of your setup?

Hi, we are using a RPi 2. here is the photo with the setup

Could you please try to run the examples without HDMI / USB devices connected (over SSH\Ethernet)? Will it work?
What is the power supply you’re using?

Now, it has started to work even with everything plugged (like in the picture)… We are also thinking on a problem with the power supply although we are using the official raspberry pi power supply (5V micro USB, 2Amp)

The issue might be not in the power supply itself, but in a poor usb cable.

You can check actual voltage on the board by running this command:
cat /sys/kernel/rcio/adc/ch0

If it is under 4.8V you have power supply issues.

I am having a similar problem. I’m using the Navio2 and the Raspberry pi 3
When connected via the usb cable and I check the voltage using the command in the previous post I get 4890. Whenever I try to run the AccelGyroMag under C++/Examples/AccelGyroMag I get the that the sensors are not enabled. It worked previously

What about other examples? Have you screwed the board down to the Raspberry Pi? Almost all problems with sensors not getting detected arise from attachment issues. I’d also like you to post the output of i2cdetect -y 1 here.

Sorry for the late reply. The board is screwed down very snug. The LED example works, and the AccelGyroMag is working now. The image below is what get for the i2cdetect -y 1

When I try the APM command from the setup document, I get the error below

What image are you using? Anyways, we recommend the newer one. It seems like you’d used the older and typed sudo apt-get upgrade at some point.

I used the image mentioned in the link you provided and I followed the instructions on the webpage. I should have the current image

There’re two of them! Could you please post the output of uname -a?

I just reload the Navio2/Raspberry and that seemed to work. Thanks for your help