Problems with RT image 20160408

Hi All,

I have just unpacked my Navio+ with Pi B+ after relocating house.
I thought that I would do a clean install with the latest image.

Unfortunately things are not as smooth as I had hoped.

  1. The Wifi dongles which previously worked are no longer working
  2. My Huawei Wingle is no longer recognised
  3. Gstreamer does not work as before.
  4. I am getting an error with APT when doing upgrades - libc-bin (2.19-18+deb8u4) is not upgraded/installed properly.

Regarding point 2) above it seems that usb_modeswitch that is installed is very old. It is possible to implement udev rules to avoid the issue.

I removed and reinstalled gstreamer1.0 but now when I try to run it with a script that worked before I get warnings and errors "Failed to load plugin …/

Anyone else experiencing problems?


@Gary Hi! New image is created for Raspberry Pi 2 and Raspberry Pi 3. We do not test it with older Raspberries and cannot guarantee that it works properly with them. I strongly suggest upgrading to a new Raspberry Pi.

Sorry, my mistake. It is a Raspberry Pi 2.

@Mikhail, I also have an error on startup:
"-bash: /usr/lib/git-core/git-sh-prompt: cannot execute binary file"

Has my image been corrupted or are these errors in the original image? I don’t really want to re-install the image as I have done some work to get the Wingle working.

@Gary try to write the image on another SD card and boot with it to check if it is working fine.

To close this off. I used a different SD card and a new image and the problem went away. I suspect that the card was failing