Problems with PPK Mavic3E datasets

Hi everyone.
I’ve already bought an RS3 and i’m doing some dataset trying to get good results.

I’ve setup the RS3 for input ntrip correction, and connected for Ntrip local output to M3E, for RTK corrections.
The M3E in RTK works fine, with errors compatible with its specifics. I’ve put some GCP, collected with the RS3, and they’re aligned with some known points in the area. Overall precision is about 5cm over checkpoints.

So RTK for RS3 as base and rover are perfect.

The problems starts when trying to process data for PPK in Emlid Studio.
As i said, the RTK data is pretty good, but i’m trying to improve the results. The RTK was on during flight.
I Logged the RINEX and then exported, processed as described in the photo tags were completely away its original position, getting errors from GCP in terms of meter, in one dataset about 7m, in another one 12m. All tags is PPK with FIX 100% in Emlid Studio.
So there’s definitely something wrong in the workflow, probably in Logging function.

My workflow is:
-Turn on the Rover. Using NTRIP correction (same used for RTK collecting data) getting FIX and Tilt calibration.
-put the RS3 with a tripod, in Base Settings completing a Mean FIX base point data of 2 minutes.
-Once base is set, start Logging with these settings:
RAW DATA RINEX 3.03, set to DEFAULT. Logging interval se to FULL RATE, all satellites except SBAS. Info Rinex header: same measured height of 1.8m as the Base settings and point collection. Position track enabled with LLH and RTCM3 base correction.
-waiting a couple of minutes and then flying my mission.
-after the mission, shut down the M3E as usual.
-wait another couple of minutes before stop logging.

What could be the issue?
Here’s the 2 missions file (rover and rinex from base) with these errors.
https://drive.google.com/drive/folders/1zlweXBjWyhezaoD9HcJFPOfDCnp6xrGF?usp=sharing
In the mission 1 folder, i’ve made a mistake: in the log settings i forgot to set 1.8m measured antenna height, it was set to 0.
The mission2 folder are ok.

PS: i’ve tried to PPK even with RedCatch toolbox, it gave me error that rover and base have no overlap times.
As i said, i turned on logging with the base before starting the M3E, and shutting down the M3E before stop logging.

1 Like

You can open the rinex files in an editor such as notepad++.
I always use this as it can view large files.

Just check the header information to see if both files have common time overlap

2 Likes

Thank you, of course I’ve done, the base rinex has +2 minutes before and +1.5 minute after the M3E rinex. Maybe it needs to be more time?

Then I think I’ve figured out the errors in positioning. I thought the base rinex Header position took the calculated base position after the Mean Fix calculated in the base settings.

But I think it’s not, because opening the rinex the line description is “Approx position”. And I cannot check if the position is correct because I didn’t measure the base point (I haven’t saved the point).

I think the problem is this, this morning I’ll make another dataset measuring the base point and insert the coordinates manually in PPK process. Let’s see if this will solve!

The problem lies in the base position on the Emlid studio.
You should always record the lat,lon,h of the “correct-fixed” position of the base station. Rinex file has approximate position as you say.
I’ve done 2-3 ppk tests with Emlid M2 and Mavic 3E and the differences between ppk and rtk solution was within 1-2cm.

3 Likes

Thank you vgo195 for the reply. It was that.
This morning i’ve done a new dataset marking the base station. In Emlid studio set the ppk base point manually and the process looks good.
Now i’ve processed the 2 dataset, with the RTK exif and the PPK, and they look pretty the same, maybe the PPK a little better, checking over about 30 checkpoints, but not so far.

So main problem solved.
But now i still have issue trying to process with RedCatch toolbox (easier than emlid studio because it keeps the orientation and the precision infos, please emlid update studio with these process option!), it keeps me saying the time of obs file are not overlapping.
These are the files:
https://drive.google.com/drive/folders/1A7eYuR4IM4VPHlVpUVGhyA0BvywYNAAh?usp=sharing
If someone are looking into it, you can see the emlid obs time is from 9.01 to 9.33, the M3E from 9.11 to 9.30.
I’ve asked also to redcatch support, waiting for their answer, but in your opinion, what is the reason for this error?

Hi Alessio,

I just wanted to confirm that the coordinates in the RINEX header are the last calculated epoch coordinates, and you can only get relative accuracy with them. To ensure accuracy in post-processing, you must manually enter the correct base coordinates. We recommend collecting this point in the project, as the coordinates will not be lost, and you will be able to use them in PPK.

easier than emlid studio because it keeps the orientation and the precision infos, please emlid update studio with these process option!

I’ve added your request as a +1. Thank you for sharing!

I’ve checked your logs and don’t see any issues with a time well. So, maybe Redcatch support can share a light. I was able to process files in the Emlid Studio with a 100% Fix:

I see that the drone navigation file has only five satellites. A small amount of satellites in the navigation file can cause issues during the post-processing. Do you use the nav file from the drone in RedCatch? Maybe that could be the source of the error in Redcatch.

4 Likes

Thank you very much for the reply!
I thought the header of the rinex filex obtained the real base coordinates, because i’ve started and stopped logging while the base was set in place.
As you said, with the manual position it worked perfectly.

I’ve checked your logs and don’t see any issues with a time well. So, maybe Redcatch support can share a light.

For redcatch issue with the gps time, it was a bug of the version 3.1.0 of their software, they sent me a trial license of the lastest update (3.1.2) and everything worked fine with the same files.
Thank you for adding my request for Emlid Studio. I can fix it on my own exporting EXIF data from the RTK project and editing the CSV file, but it will be much easier if it will do automatically :slight_smile:

I see that the drone navigation file has only five satellites

I’ve checked the NAV files of the M3E dataset and i’m a bit worried. That nav files is created directly by the drone, i’ve checked the dataset i’ve done in the last few days and this is the only one with 5 satellites (during that flight i haven’t any RTK issue, with 28-30 satellites visible).
Maybe a M3E error while writing the nav files?
This also explain why checking on 50 control points captured with the RS3, i had about 5-10cm error in Z and about 5 in XY, with 1.5cm/pixel gsd it was a strange error value, too big than usual.

I’ll try with another dataset captured the same day.

1 Like

This is what I’ve been saying. Everyone seems to think the coordinates are accurate when you bring in the Rinex or UBX but it’s not, it’s just based on uncorrected coordinates