Problems with mavlink in Mission Planner

I just tried to connect the reach rover to my 3DR pixhawk. The Pixhawk has been flashed with the emlid binaries (plane). Mission planner connects using mavlink (I have tried two sets of radios, one 433 and the other 915). When I reset the sik link using raw data and unchecking ECC neither will make a connection (i.e. all I get is timeout).

Any suggestions as to what I might try next? Am I missing something.

Thanks in anticipation of your help.


These are 3dr radios v2 (433) - has anyone got these working with ecc off and rawdata transmission when connected to the pixhawk? The radios work fine when ecc is on and mavlink data selected but I am assuming this does not give sufficient data transmission rate for the embedding of the reach gps data? All radios have had their firmware updated.

Could you please post a screenshot with their settings?

Ok this is working now but when I disable ECC it fails to connect

Please try to connect both radios to the computer and open them in terminals (RealTerm or TeraTerm on Windows). Do you see the data you type in one terminal appearing in the other? And vice versa.

Yes communications work both ways.

This just seems to be an ecc issue - is it necessary to turn it off?

Did you try the terminals without turning off the ECC?

Sorry ECC is on - do you want me to try in the terminals with ecc off? I assume I have to turn it off in the SiK configuration of MP?

Sorry if I didn’t make it clear - yes, please turn off the ECC on both radios, save the configuration and then try the terminals.

no they do not work with ecc off.

Please try to connect the remote radio instead of the local one and check if it has the proper settings (in local tab now).

sorry I do not understand what you are asking me to do. Are you asking me to connect to a remote radio connected to the pixhawk and load the setting? With ECC on or off? I do not understand the local tab now comment - sorry

ok I just tried the radios (with ecc off) with the remote connected to the pixhawk and guess what it connected :slight_smile: As far as I can tell we have done nothing and yet now it works - I wish I understood why?

Glad that it’s working now! Probably ECC off parameter never reached the remote radio by some reason, so the radios had mismatching parameters.

Many thanks! The GPS injection appears to be working but I have a poorly constrained base station (which I keep moving :smile: ) so cannot check the solution. Still much to learn but I am on my way now thanks to your help. Now to get this in the air. Incidently I have a sony a6000 with tuffwing hot shoe triggers in the post - hopefully you will be able to share your camera trigger routine soon - I am sick of collecting GCPs!
Best wishes