Problems with current reading on Navio2

as suggested i opened a new topic for reading of current of the Navio2 board

as to the current readings, even with a couple of amps drawn from the battery i get 0 readings
also i cant measure any noticeable change on the adc input for the current sensor.
tried two different power-boards, both are working on an old apm2.6, so a hardware malfunction on the
the power-board side is ruled out. something wrong on the side of the Navio2 im afraid.
I think ill get a more reliable sensor for my Jeti-system and forget about the power-module, but thnx
for the suggestions but you probably should look into that issue, i seem not to be the only one having
problems with the current sensor…


Could you please try this example out? This might shed some light onto the issue.

i did, nothing on A3
im running it without props full throttle, my current-meter shows me 2.6A and it gives me the same readings
as without full throttle, as i told you nothing, and its not the power module, it works on an amp
Voltage readings are fine as you can see …
A0: 5.1900V A1: 0.0140V A2: 2.1640V A3: 0.0000V A4: 0.0200V A5: 0.0320V
A0: 5.2140V A1: 0.0120V A2: 2.1680V A3: 0.0000V A4: 0.0080V A5: 0.0320V
A0: 5.1820V A1: 0.0120V A2: 2.1640V A3: 0.0000V A4: 0.0340V A5: 0.0140V
A0: 5.2340V A1: 0.0120V A2: 2.1640V A3: 0.0000V A4: 0.0080V A5: 0.0320V
A0: 5.1660V A1: 0.0000V A2: 2.1640V A3: 0.0000V A4: 0.0320V A5: 0.0140V
A0: 5.1480V A1: 0.0120V A2: 2.1640V A3: 0.0000V A4: 0.0300V A5: 0.0140V
A0: 5.1580V A1: 0.0160V A2: 2.1640V A3: 0.0000V A4: 0.0180V A5: 0.0320V
A0: 5.2000V A1: 0.0040V A2: 2.1640V A3: 0.0000V A4: 0.0080V A5: 0.0320V
A0: 5.2160V A1: 0.0160V A2: 2.1660V A3: 0.0000V A4: 0.0320V A5: 0.0160V
A0: 5.1800V A1: 0.0140V A2: 2.1640V A3: 0.0000V A4: 0.0320V A5: 0.0140V
A0: 5.2340V A1: 0.0160V A2: 2.1700V A3: 0.0000V A4: 0.0200V A5: 0.0320V
A0: 5.2340V A1: 0.0140V A2: 2.1680V A3: 0.0000V A4: 0.0200V A5: 0.0320V
A0: 5.1960V A1: 0.0160V A2: 2.1640V A3: 0.0000V A4: 0.0200V A5: 0.0320V
A0: 5.2140V A1: 0.0080V A2: 2.1680V A3: 0.0000V A4: 0.0080V A5: 0.0320V

Could you measure voltage on ADC1 (A3 in example)?

that what i did first, no measurable values

I’m sorry it’s taken me so long to reply. The post just sank to the bottom too fast, feel free to bump any topic of interest!

There’s a couple of thing that can go awry. Most can be fixed.

Could you please verify that these two pins are not short-cuircuited and also measure resistance between the two. Please, perform these actions with the power off.

Did you use another power chord connect them? I’m asking to rule out the possibility of a faulty connector.

np, i dont measure a short, everything seems to be fine
resistors at the navio2 are 20k, or ?! (ADC0(A2) and ADC1(A3)) measured against ground (without power module connected)
on the power-modules i have (all 3) i measure 1.36k(ADC0) and 110k(ADC1)
on the APM i measure 35k against ground, thats the only difference i can make out

Are you sure your connector is not faulty? Is there a way to check with another one? Have you dried to draw more current? Current below several amps may not be noticeable.

Can you try rover firmware. Just built a copter and no current. Just built a rover and current worked. However we used a different power module on both so can not rule out hardware issue on our side yet. Will be building another copter this week and will let you know what we find.

tried that and i dont think the conntor is faulty, checked it several time

thnx maybe i try that out

Just finishing a copter build that uses an attopilot180. Current is working. Barely reads at 3 amps and not at all accurate at 6 amps but I’ll blame the current sense for that one.

BTW I a working on building a proper dummy load with two 2 ohm 100 watt resistors in parallel. That should yield a 1 ohm load with enough power handling so we get 12 amps at 12 volts. Should be enough to calibrate these things without need for motor and props.

Hi @sicherlich_nicht.

ADC on Navio can detect current value from Power Module if current is more than 3A.

I’ve done few tests and got the following results (current on PM : value measured by ADC):
2 A : 0,0V - 0,002V
3 A : 0,012V - 0,02V
4 A : 0,025V - 0,036V

@coby: good idea, i have something like that to deep-discharge defective lipos before discarding them.
i could adapt that for testing the current monitor, maybe a way but there are also other issues

the table i posted above was measured at about 2.6-3A, (2.6A was the minimum)
according to your measurements it should have shown at least some values bigger than 0
but A3 are all 0.0000V, maybe i try cobys idea to confirm when i have time

maybe with higher Amps it will show something useful eventually but thats not really accurate then.
From my point of view those current measurements are rather useless when it comes to monitor your
battery capacity, only the voltage can give you a hint how much longer you can fly. For a small copter (<1kg) thats ok, if its falls nothing really bad will happen. But my Hexa will weigh about 3-4kg. There is no margin of error i would accept, especially when it comes to such basic readings like current and voltages

I think i scrap that “internal sensor” and use a proper and accurate Current/Voltage Sensor from Jeti (MUI 75).
That one starts measuring current from a few mA up to 75A with 1% accuracy and Voltage up to 60V 0.1% accuracy.
In fact i probably scrap the whole navio, if this is not working and the compass issues (though i think the problem with inconsistence compass values are related to the i2c-bus, but thats an other topic), i really do not trust the navio at the moment for a heavy copter, maybe i put it in something smaller or something that does not fly :wink: