Problem with uart plug and setup

Hi! I bought a 433Mhz radio (Im located in Korea) for telemetry purposes, and before everything I would like to test out the serial communications in a terminal to check if I can control the pi/navio2 similar to ssh.
I have it set up, but Im not sure if the plug is connecting all the way through. Is quite hard to fit the plug on the navio2 board, and Im not sure if it is fitted all the way through. This photo shows how it is set up

Is this correct? The led on the radio modem blinks, so I guess its ok.
If it is, I still cannot via terminal to the pi/navio2 usign either linux or windows.
On windows I tried to use both screen and minicom and neither one worked. I did the following
screen /dev/ttyUSB0 115200
and later after this didnt work
minicom -b 115200 -o -D /dev/ttyUSB0

I also tried to use /dev/ttyS0 and nothing

Then I tried putty on windows and also negative.

Do I have to write any line of code on the pi/navio2 ? All that I did was just plug in the antenna on the navio, the other antenna on my laptop USB and try to connect,
If I am missing something please let me know.

i believe your plug is not completely plugged in, though connection seems to work as your modem is powered;
correct adress for uart on rpi is /dev/ttyAMA0

on Navio start Ardupilot:
sudo ArduCopter-quad -C /dev/ttyAMA0

in windows you should look for a com port for your modem;
you need to install an GCS like missionplanner in windows for communication;

to ssh into rpi/navio you will need to connect navio/rpi to a wifi or ethernet!

Hi, thanks for the reply! There are a few things though that I fear you might have misunderstood me.

First, about the cable, I would agree with you. It looks that is not fitted all the way through, but I tried really strongly to fit the cable in and would just not enter. Still though, the LED on the uart modem is lighting up, so maybe this isn’t the issue.

Second, as I said, I do not right now want to connect to mission control or qgroundcontrol. I want to get access to the board terminal, similar to what is done with ssh. I know that ssh is over wifi :smiley: I wanted to gain access to the pi/navio2 terminal as if I was using adafruit console cabe, which I guess is possible, since that cable uses a uart too.

Third, as I said on top I am aware of the ssh connection, I have already done it multiple times :slight_smile: I just want to do it a terminal connection of the same way but now using uart.

Thanks again for the input!

yeah seems i did misunderstand you;
except enabling serial connection in raspi-config and playing around with baudrates i can’t help here… :confused:

Oh I didn’t enable anything on the pi! Is serial by default disabled?

Yes, terminal on /dev/ttyAMA0 is disabled by default. Otherwise there’s a chance something will go awry with radios.
You can enable it for debug purposes with raspi-config. But, don’t forget to disable before a flight.

1 Like

OK I will try it! I will post the feedback here after.
Just a quick follow up questions. You said i shoud disable it before a flight, so I’m guessing that to send telemetry data to mission planner or qGroundcontrol I don’t need to have it enabled??

The default baudrate for the 3dr radios is 57600 unless you changed it.

Hi guys, I wanted to do an update on this and post a slight tutorial to anyone in the future that might suffer from this same problem.
FIrst of all, I tried everything to get it working through serial connection, but no matter what it did not work. I tried enabling the serial connection on the pi, try changing the baud rate, but nothing did the trick.
Then I tried to do a more pro-active approach, and used two python codes.
The first one is a that has to run on the host computer (ground computer)

the code is as following

   #!/usr/bin/env python
    import time
    import serial
    ser = serial.Serial(
    	baudrate = 57600,
    while 1:
    	print x

afterwards, a writing code has to run on the pi/navio2. The code is as following:

#!/usr/bin/env python
import time
import serial
ser = serial.Serial(
	baudrate = 9600,
while 1:
	ser.write('Write counter: %d \n'%(counter))
	counter += 1

Then first run the on the pi/navio2, and you should see a blinking red light on the radio terminals.
Right after go to you computer and run the and you should see something like

write counter =1
write counter =2
write counter =3

ands so forth. Now you have connection and you can make a python program to send any data that you want.
Hope that helps somebody in the future

Here is my two cents contribution, i have had the same problem, the connector was not all the way in, and no connection of course. So i decided to take a look inside the connector of the board with a magnifier , i found one of the pins were bent. And carefully i took a needle and straitghted it back in place and plugged the DF13 connector, this time the connector stuck all the way in and success. My telemetry radio was back in business. Hope it works for you.