Problem with the ADC power module current input on Navio2

Since the beginning I’m using Navio2 I’m experiencing problems with the current sense input ADC1 (A3) on the power port.
Actually I never managed to read any value higher than 50 with command cat /sys/kernel/rcio/adc/ch1
or 50mV using the source code.

Other users had the same problem with power modules and if it was not a setup mistake or if they
did not changed to another module or even gave up it seems the problem has not been fixed.

I tried with Crius and CUAV 90A power modules, both of them are working on my Pixhawk with correct readings,
but when connected to Navio2 they never shows values higher than 50 on A3.
Voltage sensing is working and shows the correct input voltage of 2.4V for 6S/24V in my case.

I have shorted ADC1 and ADC2 to GND and to VCC (wires from PM removed), A2 and A3 shows correct values of 0V and 5.3V
therefore the analog inputs are working correctly.

If I disconnect the current sense wire from Navio2 then I can measure the correct voltage on it with a multimeter.
I tried to load the PM with 40W and 100W dummy charges, Whatt’sUp meter shows a current of 1.7A and 4.4A respectively
and multimeter shows:

  • on the CUAV-PM output 120mV and 310mV
  • on the Crius-PM output 50mV and 205mV

When I reconnect the wire to Navio2 it always drops to 50mV, therefore I suspect an impedance problem between
the PM output and the Navio2 ADC input.
Both of these PM are using the common INA169 current shunt monitor IC, the RL at the output are 100K on both.
As Navio2 schematics are not published I measured the resistors forming the dividers on each Navio2 ADC inputs,
all inputs are divided by two with 10K/10K dividers and have a 6.6V range:
ADC0 Power Module Voltage (A2) R20=R43=10K
ADC1 Power Module Current (A3) R21=R44=10K
ADC2 (A5) R22=R45=10K
ADC3 (A4) R23=R46=10K

Therefore input impedance on all Navio2 ADC inputs is 20K

I am wondering if the voltage drops to 50mV because the input impedance (20K) is far below than the PM output impedance (100K).

I tried to connect my current sense wire to ADC0 input instead of ADC1, same result, I also tried another DF13 harness.
For further references I measured the Pixhawk current sense input impedance, it shows 1M which is correct according to the schematics.

Of course I may have done some mistakes so any comments would be appreciated.


Thanks for your investigation.

Same problem with my Navio2 and current sensor. I had set the AmpVolt multiplier to around 150 to have something coherent.


Hello Marc,
Thanks for your sharing too. setting AmpVolt multiplier to 150 give you a coherent reading but probably
not reflecting the real current by far as you are loosing in precision, it means you are measuring on a scale
ten times smaller than the real 3.3V input range. Did you check the readings in Mission Planner against
real measurements on ampere or watt meter ?

Hello Patrick,

No direct reading, just log total current against charge… with a 10% error.

As Navio2 is my first card with Current Reading, I use to rely on Voltage and chrono.


I would like to change the divider on my Navio2 current sense input by replacing the two 10K resistors
by two 100K, keeping the 0.5 ratio but increasing the input impedance to 100K, but I’m worrying
about loosing my warranty… Feedback from Emlid about this matter would be much welcome.

Oops sorry, I was meaning replacing by two 50K for having 100K input impedance…

Hello Marc,
Are you using the power module supplied by Emlid or another one ?

Hi Patrick,

Emlid power module.

I have some PixHawk like cards (VRBrain) and I do not use current sensor with them. There is an integrated voltage monitor circuit.

I’m looking for a 6S capable module to populate my X8 and move the Navio board on it.


BTW I also tried a Mauch hall sensor and it’s working fine on Navio2, I guess it’s because it has a lower output impedance.
Sensor output is at 220mV with a 4.4A current, when I connect it to Navio2 it does not drop like the other power modules,
with an AmpVolt multiplier of 22 it shows the correct current in Mission Planner.
But this does not fix my problem as I want to use a standard Crius like power module on my setup.
When I was talking about the 100K RL at the output of power modules I was refering to the INA169 circuit used on most PM: