Problem with starting ArduCopter

during setting up navio2/rpi i i experienced “unable to open spi bus” 3 times - i set up a fresh image every time and it worked again; (i thought it was an issue related to raspi-config - since some options returned an error - and enabling spi again lead to i2c error message and then to a /sys/class/pwm/pwmchip0 -error )
but anyway:
yesterday after having that same problem again i installed a fresh sdcard - now i get the following message:

pi@navio:~ $ sudo ArduCopter-hexa -C /dev/ttyAMA0
Raspberry Pi 2 with BCM2709!

Init APM:Copter V3.4-dev (cce4f12e)

Free RAM: 262144
FW Ver: 120

load_all took 19us
Q��No INS backends availableopened: No such file or directory0 0 0 �
HMC5843: Could not detect version
MPU9250: unexpected WHOAMI 0x0

(here the screenshot: )
with a different return for starting ArduC with udp:ip:port or /dev/ttyAMA0 as seen on the Screenshot

i switched to another sdcard - but no difference;

would appreciate any suggestions

PS: this is output from ./AccelGyroMag

is it right to assume that “sudo apt-get update&&sudo apt-get upgrade” is unsafe on rpi2/navio2 ??
ArduCopter seems to work before updating right now…after updating i get:

Unable to open /dev/spidev0.1 - No such file or directory
SPIDriver: unable to open SPI bus

i didn’t install any updates before upgrading except of “autossh”


sudo apt-get update && sudo apt-get upgrade

is considered safe, rpi-update and dist-upgrade are not, though.

Could you tell please why are you trying to do anything with spi in raspi-config?

i don’t know what to do when i get the “Unable to open /dev/spidev0.1 - No such file or directory
SPIDriver: unable to open SPI bus”; So i tried raspi -config enabling SPI;

flashing a fresh image on my SD-card removes the error, but after “apt-get update&&upgrade” and reboot the error occurs again…
just testet it again:
before apt-get update&&upgrade:

after “apt-get update&&upgrade”

PS: apt-get update gives me the following message: “W: Failed to fetch 404 Not Found”


Ok, I get it and I’ll look into into it tomorrow or the day after tomorrow.

The error regarding the missing package will have been fixed by that time too.


raspberrypi-firmware package seems to upgrade kernel (this is not expected at all. The package description says that it’s temporarily, though. I guess we’re at the Raspberry Pi Foundation’s mercy at the moment for a while).

We’ll see what can be do about it, though.

If you cannot wait, there’s a pretty simple hack. You need to backup a couple of files and overwrite the files that are getting modified during the upgrade

mkdir -p ~/backup
cp kernel7.img kernel.img bcm2709-rpi-2-b.dtb ~/backup/
sudo mv ~/backup/* /boot

Something like this would do.

Thanks for your Investigation! I will make a backup - just in case - and wait!