Problem with serial data output from rover reach to PC

We are trying to remove the infomración in NMEa format from the Rover to our PC via a serial RS232 port (USB-Serial adapter), but only managed to see “junk” …

We tested the configuration (attached images and video), and only managed to see through bluetooth data in NMEA format without problems APP “Bluetooth GPS” on Android.

We tested with Serial and UART output, along with Serial and USB output …

Sometimes loses the USB configuration parameter and only shows UART … this is normal or are
doing something wrong ??

This output from the Rover (Reach) to the PC via Serial is enabled in Edison ??

From already thank you.

https://dl.dropboxusercontent.com/u/88793867/20160418_130321.mp4










Hi!

The problem is the RS232 interface. What we call serial in Reach is actually a TTL UART. You will need a converter to make it work like this.

Dear Egor, we probe the USB OTG output to PC USB connector, and we get the port COM 4 assigned to REACH on WIN7 with all baudio setting (manager device) , but the are not data nmea in (binary data), the same occurred with the UART port, we uses USB/RS232 converter, UART/rs232 converter and nothing occur. We are thinking what the are problem between Edison an Reach, same problem with internal port…?. You see the video connect to UART/RS232. The USB adapter to PC is working very good with other hardware. but whit Reach not…,

We tried with serial USB output parameter, nothing happen.

this is the problem I report since one month…

Could you please provide a clear schematic of how you are connecting wires. On your picture nothing is connected together. Why did you cut the OTG cable?

Please see the video attached in the first post.

In video you see that all running in hardware, but don’t see data in PC.

We tested all baud rates.(9600, 38400, 57600 and 115200)

We need that data correction is send to the serial port. This serial por is RS232 for a special measurement equipment (CMD-1 – http://www.gfinstruments.cz/index.php?menu=gi&smenu=iem&cont=cmd_&ear=ov) with a special unit “CMD Control unit” that receive NMEA data from serial port.

Now used this, you see in this picture:


This is what we need to accomplish. Change the current RTK equipment (base and rover) with the Reach (base and rover).

It is really hard to tell anything from the video because of the amount of wires and insulation tape. Please make a clear schematic of which wire and where you are connecting. UART output on Reach works, so there must be some issue in the wiring.

Are you sure that there is no tx/rx mix up? It could be that UART to RS232 converter has to be connected tx-tx and rx-rx . Which model do you have?

I’ve got the same…all is working good when using serial mnea on bluetooth , but in serial wired output mode the data are not correct, alway stream a fixed velue like $128 sometine $ 132 or 130… instead of the mnea patern…

i Try the 3dr radio on usb or serial input and test all the output of the reach , nothing to do only bluetooth serial work.
I test wilth all the baudrate possible.
maybe a bug betwhen reach view writing saving and the script file maybe corrupted or not updated…

but in apm use all is working correctly…

How are you wiring it when you get [quote=“tazdevil, post:11, topic:2392”]
$128 sometine $ 132 or 130… instead of the mnea patern…
[/quote]?

Can you provide exact steps to reproduce the error?

We have made a reflashed for each reach. Then we set the rover and base and proven serial output, and it worked. We had data output NMEA 57600 UART, but we had no access via bluetooth. When we clean browser cache we activate the output 2 bluetooth but now we have again the problem of serial output, and we returned to have no NMEA output by the serial port.

What happens then ?? why when configuring the UART output after reflashed worked, but to activate the bluetooth as output 2 serial stopped working and no longer worked ??

Has I think there is a little bit of script corruption somewhere…

if we need to reflash every time the edisson…

is there a way to check all the configuration or init file somewhere by ssh with putty ?

I m pretty sure there is a bug with the save setting on the config file…

it could explain lot of strange bug we have like this one

Can you reliably reproduce this error? So every time you enable solution output 1 on Bluetooth, solution output 2 over serial stops?

If you drop config to default (by pressing on 3 dots in the config menu and choosing revert to default) and configure NMEA over serial only, would it work?

Which version did you use?

@tazdevil If you are experiencing any issues please report them in a clear way, such as exact steps to reproduce. If we can reproduce something it gets fixed pretty quickly. By the way, issue with config corruption that caused some weird bugs has been already fixed. Please update.

We were able to reproduce this issue and will update this thread after it is fixed.

good to know and thank for have testing it.

Seems to be fixed in v0.3.4. Please update and try.

###Warning###

This might require clearing your browser’s cache. Exact steps for Chrome and Firefox are described here.

Thanks for all!.. now we get data with serial output from rover reach to pc…

Regards,

1 Like