Problem with sending commands Navio2 using telemetry


I have setup Navio2 with telemetry to connect with APM Planner and QGroundControl.

I have the following command on Navio2
sudo ArduCopter-quad -A udp: -C /dev/ttyAMA0 > /home/pi/startup_log &

running automatically from /etc/rc.local.
Using UDP all is working fine.

When using only telemetry, the ground station detects the drone (through hearbeat) but no command could be send nor any parameter could be read.

When I arm the copter using a RC, it arms and the ground station notify the arming event. However, if I sent an arming command (or any other command, like change flight mode) from the ground station, nothing changes.

In QGroundControl , there is a warning message stating: “Vehicle did not respond to request for parameters, retrying …”

So, this means that no parameters was read from the copter and thus no command could be sent.
I do not understand why this happening and how to solve the problem

As I mentioned, with UDP is works quite fine, only with telemetry.

Any help on this will be appreciated


How exactly do you launch ArduPilot?

I launched ardupilot as
sudo ArduCopter-quad -A udp: -C /dev/ttyAMA0 > /home/pi/startup_log &

It seems my problem is solved.
I tried another telemetry device, and it worked fine.
Then, I used the same telemetry device that did not work and seems to be working now.

It would be a bad connection of wire or just temp problem

Glad, the issue is gone :slight_smile: