Problem with navio2 connection to missionplanner

I installed missionplanner 1.3.46 to my laptop which is on windows 7. I configured NAVIO2 via ssh to run arduplane automatically and it works fine.
And now I need to connect NAVIO2 to that mission planner. The problem is that missionplanner doesn’t connect to the device. When I open device manager, there is no COM port seen.

I kindly ask you to tell me how to fix that problem. Any assistance would be highly appreciated. Thanks a lot.

Hello,

How do you try to connect?

Are you at home on your local network or outside?

There are more than one way to connect Navio2.

Pi Wifi to your network (UDP)
NAVIO UART —Telemetry radio — — Telemetry Com Port on computer
Pi USB —Telemetry radio — — Telemetry Com Port on computer
Navio UART — Ftdi USB — Computer

Marc

I am trying to connect to NAVIO2(which is on raspberry pi) via ethernet cable

Hello,

Ethernet is fine for SSH connect and UDP.

https://docs.emlid.com/navio2/common/ardupilot/installation-and-running/#specifying-launching-options

Where you have:

TELEM1="-A udp:127.0.0.1:14550"

replace 127.0.0.1 by the ethernet address of the computer running Mission Planner.

Mavlink Mission Planner COM port connection (or other GCS connection) had to be done via UART (telemetry radio or UART to USB Ftdi link).

Marc

1 Like

thanks a lot. It works fine now

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.