Problem with Navio+ and GPS

Navio+ GPS doesn’t show any lock , and in mission planner it shows gpsstaus=0
even though ublox centre shows GPS lock. I run Ublox centre with link to Navio+ through the
ublox-spi-to-tcp utility in pi. I use pi3.

I have even tried external GPSs with -C option and -E option but this didn’t work too.
I cant think of something else to do.

Following are some screenshots.

I am using the Emlid Raspbian Image for Navio2/Navio+ (emlid-raspbian-20160408) image
The arducopter command i send is sudo ArduCopter-quad -A udp:

Hello there!

Please try running this version.

could you please tell me how to install this version and uninstall the one i have ? I m not good with linux :slight_smile:

Isn’t this the version i use ? On my second picture it says 3.4 rc1

How exactly have installed APM at the first place?

I guess sudo apt-get install apm-navio-beta?
I was thinking you tried the stable first.
In order to uninstall a program you need to use apt-get

In short,
sudo apt-get remove apm-navio-beta
sudo apt-get install apm-navio

Should get you a stable release installed.

Forget about the link I just shared for a while. (this was only because I’d assumed you’d been using another version). Sorry for the confusion.

sudo apt-get remove apm-navio-beta worked ok … but

sudo apt-get install apm-navio didn’t work i was getting : “E: Unable to locate package apm-navio” message


i installed apm-navio the old way …

wget ‘’ -O apm.deb
sudo dpkg -i apm.deb

apm v3.3 installed as it seems on the picture … but still no GPS ;(

this is my first time with navio+ , never used it on a drone yet

Could you please erase old parameters and try again.

Run sudo rm -r /var/APM to delete them.

strange result now :slight_smile:
seems to work as it shows on image … now i have a location , hdop 2.9 on map (not expected good where i put the gps) but also 99.999 on the left


but gpsstatus is still 0 !!! . What do you think about it ?


Could you please enable DisarmedLogging in parameters. Restart and send us a log. It seems taht the issue has gone away, though. I do see GPS: 3D Fix on your screenshot.