Problem with Benewake TFmini

I am using a 3DR Radio module for telemetry on TX/RX of the UART connector and I am having trouble setting up the Benewave TFmini

My configuration

IO17 > White Wire (RX)
IO18 > Yellow Wire (TX)

/etc/default/arducopter

TELEM1=" udp:129.168.8.181:14550"
TELEM2="-C /dev/ttyAMA0"
TELEM3="-B /dev/ttyAMA1"

ARDUPILOT_OPTS="$TELEM1 $TELEM2 $TELEM3"

MissionPlanner.

INITIAL SETUP - Optional Hardware - Range Finder = Benewake TFmini

CONFIGTUNING - Full Parameter List.

RNGFND_TYPE = 20
SERIAL3_PROTOCOL = 9

I get

Distance: 0
Voltage: 0

I’m sure that I’ve not got something set up right here?

Any help would be great. Thanks

I will have one TFmini soon. I expect to use the UART (I use USB for telemetry).

So we can share our experience.

1 Like

The Raspberry Pi has only one UART. You need to use an USB to UART adapter for the TFmini.

1 Like

Thanks Bret,

I’m going to try and set it up today with an FTDI-232 cable.

I have it working!

But my sonar range is reading approximately 4 x greater than the actual distance.

Does anyone know how to set the scaling on a serial range finder? I only see m/v setting which is analogue right?

It seems that there was a fix to this on 3.6.2 for the TFmini scaling issure and I am running 3.6.11.

I have spent a lot of time setting up my copter as a single.

Does anyone know if the upgrade will lose any of my settings?

Hi @LeeM,

Yes, after updating Ardupilot all settings will be reset. However, you can backup your settings in the Mission Planner:

  1. In the Config/Tuning tab, open the Full parameter list

  2. Choose the Save option in the upper right corner

Then, you can just restore your parameters after the upgrade.