Problem with barometer readings on Navio 2

Hi everyone!

First, I would like to apologize for my poor English.

I am using Navio2 and RPi3 in order to build a quad-copter. The version of Arducopter is 3.4.6, and the RPi3 is working on the most recent version of the Raspian you provided. the network is working, the sensors MPU and LSM are working with the C++ an python examples (not in python for LSM). However, when I want to test the barometer, I am facing a few errors in C++ an Python.

We can see that in C++, the values of the sensors are constant and not significant.

Moreover, when I try to connect to the GCS (APM planner2 or Mission planner), there is communication with the RPi3/Navio2, but the GCS is blocking on “Calibrating Barometer”

The problem is the same with mission planner

I tried to look for a solution, and found that the I2C bus was like “empty”, but I don’t no if the problem is coming from that.

When I tried to comment the line i2c_bcm2708 in the file /etc/modprobe.d/raspi-blacklist.conf to have access to the peripherical connected to the i2c bus, I found nothing in this file as it didn’t exist.

I am very confused and have no solution.
I would be glad if you have any solutions.

Hello Fabien!

Thank you for your elaborate report. Really appreciate the effort.

There’s a couple of things we should try before giving up.

  1. The output of sudo emlidtool is of interest to me.
  2. Could you please send us photos of your setup? I’m particularly interested if you screwed the Navio2 down.
  3. Could you please also post the output of dmesg before and after running i2cdetect -y 1?


Thank you for your quick answer.

This is what you asked for :

I precise that nothing is connected to the Uart and power ports.

This is the result with the SSH connection, but with a simple connection (keyboard and screen), the pwm line returns "failed Reason : [Errno 13] permission denied : “/sys/class/pwm/pwmchip0/export”

the return of the command is a bit long, but I suppose you are interested in this line (If not, tell me what you are looking for) :

after the command :

During the time I was waiting for your reply, I did some things :

  • Add the line “i2c-bcm2708” to the file /etc/modules ( I already the line “i2c-dev” in this file)
  • Add in the file /boot/config.txt the line “dtparam = i2c_arm=on”
  • reboot, but nothing had changed
  • apt-get install python-smbus libi2c-dev
  • apt-get update

After this, the problem remains.

thank you again for your help.

I really need and answer, I use Navio2 for a project. If someone has an aswer…

Thank you.

Sorry, it’s taken me so long to reply.
I’m more interested if there’s anything suspicious (any errors or warnings) issued after i2cdetect. If there’s none, try giving a little push to Raspberry Pi header and hold it as tight as possible to eliminate any connection issues and repeat. If nothing changes, we’ll arrange a replacement.

I found this errors on the return of dmesg before and after i2cdetect, but I suppose it’s not the solution.

The raspberry Pi is well connected and there is still the same probleù

Sorry to hear that. Please, write a letter to with your order number and a link to this thread to arrange a replacement.