Problem Updating RS+, Free WiFi

Hey All,
I am having trouble updating one of my two RS+ antennas, which I use in base/rover RTK mode and integration with a GSSI Utility Scan ground penetrating radar (although the integration is working fine and is not the problem). This is my first large scale project with the two together. The Emlid equipment was purchased in the last two months from Event 38.

After having success yesterday, but some minor RTK fix issues, I decided to try an update for potential RTK fix improvements using a hotel wifi. Although the specifics are blurry to me, I ended up in a state where I thought I needed to flash it and then update. The driver install is successful with my Windows 10 machine (2.14 image) and I can begin the update process as detailed here and in the docs. I get to the point where I connect the antenna with my Android phone via the update app, I specify the network, and it tells me to connect to the same network. I do so and the RS+, after blinking fast, goes to the slow blue blink, which I believe means it has connected to some network.

At this point, I get nothing from my phone. I can’t recall if I automatically go I to the next step in the update app or I go back to search for a device or restart Reach View, but either way I get no reponse.

I am a long way from my home base and have limited resources here, but have driven around to numerous free wifi connections. Some are 2.4Ghz and some are 5Ghz (this was a question for me), but all produce the same results. All are open networks with no security. In the past I have used two home networks with security successfully, so I wonder if this is a problem.

My other specific question is whether connections where you have to check a “terms of use” might be an issue. However I have used those and completely open ones with no success.

I have used the Fing app and cannot find the RS+ on the network, although I remember in one case late last night I could see it - again with no success. I have also tried a Nvidia Shield tablet instead of my phone with the same results.

I have also tried connecting via browser on two Android devices and my Win 10 laptop. A remaining question is should I, as a failsafe, be able to connect via browser and IP address if I am generally running with the Android app otherwise. Anyway, has not worked so far.

I appreciate any help here. I’m in tough spot trying to complete a project and on a budget. I currently cannot collect any data because my Rover is inoperable. I might be able to offer screen shots and other info, but am on limited rsources in the field in rural Texas.

Thanks much.
Bryan

1 Like

I’ll clarify my post into two smaller inquiries:

  • What are the specs (if any) of a network that a RS+ can connect to?

  • What are the specific issues that might keep a Reach RS+ from connecting to a network?

Connecting to a network seems to be the only step that is an impediment to getting me back to RTK survey. I’ll add that I never had previous issues during initial setup or firmware update, so trying to isolate the problem here.

Some additional info: when I connect to my hotel free wifi on the RS+ and check with Fing, I do see the Murata hardware, but it disappears pretty quickly.

I am home (to New Orleans) tomorrow and will try my tried and true wifi personal network there. Hopefully that will fix the issue and I can complete my survey next week.

It would still be good to know what is happening here for the future. At this point I would advise anyone to not try updates while in the field. I certainly won’t.

The 2.15.4 dev firmware contains some fixes for wifi. Maybe try that out, at least it works a little better for me.

Free Wi-Fi networks quite often prevent connection between devices in the network. This is done for security, but could prevent you from seeing the device in ReachView.

2 Likes

With this experience in mind (the fact you can basically accidently brick your RS+), I have two suggestions then:

  • The ability to update via the USB cable when connected to a PC. You can flash this way, so why is a direct wifi connection necessary for any part of the process?
  • Some sort of warning that this might be a problem.

Related to newer updates, I have only found the 2.14 image online and am therefore unable to try 2.15.x. If there is a link to the image out there, please let me know. Because I can’t get to the check for updates portion in the Reach View Update, I can’t try the new update.

I have done this. If you can wrangle network commands in Linux, then you can too. Obviously it is not for everyone though.

I don’t think you will brick your device. If you are able to connect to ReachView, and select the update, it would just fail to download the update and then stay at the same version. No bricking here!

You are correct, stable is available as an update or as firmware. Development is distributed as an update only.

Back on my familiar wifi network and everything is updated to 2.15.4. I’ll give it another go with my project next week. In retrospect, I’m not exactly sure what I did in the field that (I thought at least) required a flash, but once I did that I was stuck in the update loop and couldn’t get past the network connection stage. I do have a Linux enumulator on my Windows 10 laptop and that might be a good avenue to explore for the future. I’m good for now though. Lessons learned through this process at least. Thanks to all who posted here.
BH

Also take a look here: Connecting Reach RS+ to Home WIFI

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.